1 Reply Latest reply on Jul 21, 2012 11:28 PM by philmodjunk

    [Full Access] Script doesn't work with External Data Sources... any work-around?

    rensys99

      Summary

      [Full Access] Script doesn't work with External Data Sources... any work-around?

      Product

      FileMaker Pro

      Version

      FMP Advanced v10.0

      Operating system version

      Windows XP, IWP and FMP under Filemaker Advanced Server v10.0

      Description of the issue

      [Full Access] Script does'nt work under these conditions....

      - Using a data separation model with Scripts in main file, and data in External Data Source with .fp7 file

      - Privilege Set in External Data Source for certain data elements set-to 'view only' for certain Accounts and certain data elements with 'Limited' access

      - Same Privilege Sets being used in the main file

      Now... we have a script (in main file) set to 'Run script with full access privilege' -- but when logged in as an Account with limited Privilege Set, the script will not execute 'Set Field' for the target field in the external data source which was set-to 'view only' for the log-in Account with limited Privilege Set.  

      This script should execute as if it were being run under [Full Access].

      Are we doing something wrong? Or is there a work-around for this apparent issue?

        • 1. Re: [Full Access] Script doesn't work with External Data Sources... any work-around?
          philmodjunk

          Quoting from FileMaker Help:

          In the "Creating and editing scripts" entry:

          The Run script with full access privileges feature only functions in the file in which the script is defined. This command will not override access restrictions on external files. For example, a script to delete records in File A that has the Run script with full access privileges option enabled will not delete records in an access-restricted external file File B.

          One work around is to use Perform Script to perform a "run with full access.." script placed in the external file.

          Another work around is to modify your privilege setttings so that "run with full access..." is not needed.