8 Replies Latest reply on Aug 8, 2011 2:06 PM by TSGal

    3G Connection issue not VPN or Port Related

    JeffMiars

      Title

      3G Connection issue not VPN or Port Related

      Post

      Current setup:

      iPhone iOS 4.0.2 Running Filemaker Go 1.0.3
      iPad iOS 3.2.2 Running Filemaker Go 1.0.3

      Using 3G on Filemaker Go, connecting to a hosted website (I use austinmichael.com and fmgateway.com: both have the same issue)

      If I'm using my iPhone 4 on 3G, I can connect to either database no problem.

      If I'm using my iPad on 3G, I CANNOT connect to either database.

      Since I was able to connect using my iphone, I assume this is not a port forwarding issue on either hosted site, and VPN is not needed obviously since I did not need it to connect on my iphone. These are the 2 most common issues as posted on the forums and in the filemaker documents.

      So.....Why can't I connect to these databases using Filemaker Go on my iPad over 3G?

        • 1. Re: 3G Connection issue not VPN or Port Related
          JeffMiars

          Here is the Solution and how it is reproduced:

          Start with your iPad off, boot it up and do not have it automatically connect to any wifi network. Immediately after it boots up, open filemaker Go and try to connect to your hosted database over 3G. It does not connect or see any databases. Even though you might have 3G, My guess is because Filemaker Go does not think there is a 3G connection because nothing has been loaded yet on 3G,  it will not show anything to you to be able to connect.

          YET! Follow the same steps but instead open safari before you open filemaker go, have it load a page, go back to filemaker go, you’ll be able to open any hosted database like before, no problem.

          As a side note: I ended calling AT&T and if you go into settings>General>Reset>Reset Network settings    and reset it, any problems you had with AT&T saying your data is up but is actually not, is fixed.

          ADDED 9/22/10.....As of 9/22/10 iPad Filemaker Go 1.1.1 still has issue

          • 2. Re: 3G Connection issue not VPN or Port Related
            TSGal

            Jeff Miars:

            Thank you for your posts here and at iPad 3G Connection to Online Hosted Database Fails to Connect

            I have been unable to obtain an iPad with a 3g contract, so I have been unable to test.  However, I am submitting your results to our Development and Software Quality Assurance (Testing) departments for review and confirmation.  I will keep you posted when I receive any information back from these groups.

            TSGal
            FileMaker, Inc.

            • 3. Re: 3G Connection issue not VPN or Port Related
              himistu22

              TSGal,

              This problem still exists. But it seems that the steps outlined here work for now. I am checking it on 4.3 GM release right now and I will get back to you if it still is present. I had to inform my clients on how to use this. 

              Adding on, the reason why it stated to reboot iOS is because it looks like some parts of Go are still active in the background. instead of rebooting, you can just hit the home button 2 twice and the lower history menu will come up. press and hold the Go icon in that history button until the jiggle starts. Click the "X" and that will shut down Go. Hit the home button again and jiggle will stop. Hit the home again and the history panel will close then you can launch Go again and, the times I have done it, it works.

              • 4. Re: 3G Connection issue not VPN or Port Related
                BarbAvila

                Has there been any update on this problem?

                I have exactly the same problem.  I can connect via 3G on my iphone, but not on my iPad2.  I have tried all that was suggested, including rebooting and opening Safari before I try opening Filemaker Go.  But nothing works.

                I have a Verizon iPad.  But my router is a 2wire from AT&T U-Verse.  Obviously port forwarding is working since I can open the file on my iPhone.

                Any other suggestions?  This is VERY frustrating!  Grrrrrr

                Barb Avila

                • 5. Re: 3G Connection issue not VPN or Port Related
                  TSGal

                  Barb Avila:

                  Thank you for your post.

                  Your post doesn't mention how you are referencing the file.  That is, are you using IP Address or DNS name?  If you've only tried IP Address, and you have a DNS entry, try the DNS name.

                  There is no new information from either Development or Testing.

                  TSGal
                  FileMaker, Inc.

                  • 6. Re: 3G Connection issue not VPN or Port Related
                    BarbAvila

                    TSGal-

                    Sorry, I was using an external IP address.  But, the good news is, I got it to work!  I deleted the external IP host and added it again.  Bingo!  it worked!  Not sure why, I added exactly the same IP address. Whatever, it works now.

                    Thanks!

                    Barb Avila

                    • 7. Re: 3G Connection issue not VPN or Port Related
                      user14040

                      I am having the same problem on a earlier post, I can not get two client Ipads to connect on 3G using AT&T service.  I have a Verizon Iphone with Hotspot and when I connect the Ipads using My Iphone on Verizon network it connects with no problem.  

                      How can I get FMGO to work on AT&T Service?

                      • 8. Re: 3G Connection issue not VPN or Port Related
                        TSGal

                        Lawfour:

                        Thank you for your post.

                        Using AT&T on an iPhone here, I can connect to a hosted file without a problem.

                        What version of FileMaker Go is on the iPhone devices?

                        What version of iOS is on the iPhone?

                        What occurs when you enter the IP Address of the host?  Do the files display?

                        If you have Wi-Fi active, are you able to connect?

                        Any other information you can provide may help me narrow the possible causes.

                        TSGal
                        FileMaker, Inc.