2 Replies Latest reply on Jan 2, 2014 8:57 AM by VictorLimary

    Can't get "Insert from Device" to do anything

    VictorLimary

      Title

      Can't get "Insert from Device" to do anything

      Post


           I've recently upgraded to FM 13.  To test out the new "Insert from Device" function, I created a button that calls it, and specifies the target as a container object.

           However, whenever I press the button, nothing happens.  I've tried doing this in two different databases.  Am I missing some permission somewhere?  I've tried changing the insertion type from Barcode to Image to Voice Recording to Signature, and nothing happens.

           I am using:

           Windows Filemaker  Pro 13.0v1 (also tried hosting it on FM Server 13 as well)

           iOS Filemaker Go 13.0.2

           iPhone 5s with iOS 7.0.4

            

           I checked the Privacy settings on the phone, but it doesn't show FileMaker as having even requested access to photos or location services.

        • 1. Re: Can't get "Insert from Device" to do anything
          philmodjunk

               I've been able to insert images and bar codes into fields in my database without issue. When I consider ways that this script step might fail, what I can think of is that any of the "insert" scripts steps do not work unless the target field is present on the current layout and browse mode access is permitted. If the field is not present on the layout or browse mode access is not allowed, any script step starting with "insert" will fail to work.

               Insert steps also trip some script triggers that you might set on the field, so that is also a detail to consider.

          • 2. Re: Can't get "Insert from Device" to do anything
            VictorLimary

                 Thanks Phil!  It was that I didn't have the field on the layout.  I was trying to pass it a container that I didn't necessarily need to have displayed.  So when I put the field in the layout, it works.