5 Replies Latest reply on Jul 24, 2010 11:13 PM by jpierson

    Cannot connect with 3g

    MaureenPulignano

      Title

      Cannot connect with 3g

      Post

      I cannot connect with 3g on my iPhone 3gs. I talked with support today and learned that I had to upgrade filemaker from Pro 7 to pro 11 - $179 - to connect using 3g. I still cannot connect. I have tried all the hints listed here. None work and I am astounded that this is such an unfriendly user interface!

      Will one of you FM folks please give me a straight answer?

        • 1. Re: Cannot connect with 3g
          Steve Wright

          First off, it may help to find out what you are currently doing to try and connect via 3G

          When connecting via 3G you are not on your local network, therefore you need to ensure you are you using your WAN IP address.
          If this is static, you should have no issues, if it is dynamic, you will need to keep on top of it since it can change.

          You may also have to setup port forwarding on your router, so that port 5003 is forwarded to your host machine, not sure if any other ports are required, but this worked for me.

          • 2. Re: Cannot connect with 3g
            MaureenPulignano

            Thank you for your reply! I am obviosly far more tech challenged than the makers of this system anticipated. I have no idea what my WAN IP address is, or how to determine it. Nor do I know about forwarding from router to host machine. Where can i get the basic guidance I need?

            I appreciate any help you can offer - or I will recall tech support on Monday morning.

            Thanks,

            Maureen

            • 3. Re: Cannot connect with 3g
              Steve Wright

              I made a brief post here which gives a little more info than above.

              HOW TO : Connect to a hosted file using 3G on FM Go

              As for how to configure your router, look for your router guide either online from the manufacturer, or one which was provided with the router which is sometimes a PDF on the CD which accompanied it

              Still no luck, do a quick google search for port forwarding and your make / model of router, Im sure there will be some info out there

              For what its worth, the same things would apply if trying to connect FM Pro via the internet rather than on your local network.

              • 4. Re: Cannot connect with 3g
                MaureenPulignano

                Thank you for your detailed post! I have my static IP and I'll get to the router tomorrow to determine what I have.

                Thanks again,

                Maureen

                • 5. Re: Cannot connect with 3g
                  jpierson

                  Hello. I am a relatively new FileMaker user and I guess we're all new FileMaker GO users. I have struggled with this myself and I finally got to see my FileMaker database on my iPhone and iPad over 3G. Make sure you have port 5003 forwarded through both your router and desktop firewall. Well, I am using a trial of FileMaker Server 11 on my desktop with Vista Home Premium. When you enter your Domain name do not lead with http:// or www or anything else. Just use i.e. "abc.xyz.com" or .net or whatever. I got my domain name from dyndns.com. But you can just use the IP Address of your router especially if it is static.

                  Here is the part that had me stumped. I had everything else set up correctly but it still seemed not to work. I would turn off wifi on my device and go straight to the FileMaker GO app and I would get "No files found" or something like that. I found that you need to go to Safari first and just navigate to any website just to "wake up" the connection then return to FM GO and it will work. I had to do this for both the iPhone and the iPad. You will probably need to do this anytime you want to go back to your database anytime you have been away from it for a few minutes doing offline activities. It seems the 3G internet connection goes to sleep to save power and FM GO can't wake it up.

                  Good luck getting your connection working.

                  James