5 Replies Latest reply on Jul 5, 2011 11:34 AM by disabled_JackRodgers

    Disabling Buttons

    TedN

      Title

      Disabling Buttons

      Post

      This may be a question for an iPad forum but I thought I'd try here first.

      I have created a form in FMP which I transfer to FMG on my iPad. The form has two types of fields, numeric and container.

      I can move between numeric fields using the the Previous and Next buttons without a problem.

      However, if the next field happens to be a container type a panel appears with four options: Choose From Library, Get Signature, Open and Email.

      I need none of these options and they will undoubtedly cause problems if a customer using the form decides to experiment with them.

      Is there a way to disable the Pevious, Next and +/- buttons, also the button that shows, omits and sorts records, etc.

      Thanks,

        • 1. Re: Disabling Buttons
          TSGal

          TedN:

          Thank you for your post.

          If you don't users to tab to the Container field, then don't include it in the Tab Order.  That is, in FileMaker Pro, go to Layout Mode, pull down the Layouts menu and select "Set Tab Order...".  The current tab order for all fields will be displayed.  Blank out the value for the Container field.  This will remove it from the Tab Order.  Then, when you open the file in FileMaker Go, you will be unable to access the Container field using the Previous and Next buttons.

          At this time, it is not possible to remove the "Previous" and "Next" buttons.  However, to turn off the sort option, you need to Hide the Status Bar and Lock it.  That is, have a script step:

          Show/Hide Status Area [ Lock ; Hide ]

          This also removes the icon for Adding, duplicating and deleting records, as well as the record slider bar in the middle.

          TSGal
          FileMaker, Inc.

          • 2. Re: Disabling Buttons
            TedN

            Thanks TSGal, that worked well.

            One other thing. When I click on a number or text field the field height increases, overlappng the field below. It seems to be adding an extra blank line when selected. If I reduce the font size this doesn't happen. It only happens in FMG on my iPad not on FMP on my PC. Is this fixable. I'd prefer not to reduce the font size.

            Thanks,

            • 3. Re: Disabling Buttons
              TSGal

              TedN:

              The field height increases when editing the contents of a field.  However, you can change this by adding a vertical scroll bar.  That is, in FileMaker Pro, go into Layout Mode, select the field, and in the Inspector, click the Data tab, and below the pop-up for Control Style, enter a check mark next to "Include vertical scroll bar".  Then, with FileMaker Go, the field will not expand.

              TSGal
              FileMaker, Inc.

              • 4. Re: Disabling Buttons
                TedN

                Thanks for the suggestion TSGal but unless the scroll bar can be made invisible I think the cure is worse than the problem. Ha ha. I'll play around with field and font size and see if I can come up with something.

                Thanks,

                • 5. Re: Disabling Buttons

                  I haven't tried this so consider it off the cuff, but if you use Inspector to increase the vertical size of the field by x number of pixels, it might not expand. Of course this might cause an overlap of fields so you will need to adjust your layout. In Filemaker Pro I see fields expand where the font is sized say for 18 pixels but the field height has been reduced say by sizing all fields to match a smaller font sized field.