AnsweredAssumed Answered

Export/Import for record merge on iPad

Question asked by bterrell721 on May 21, 2013
Latest reply on May 23, 2013 by bterrell721

Title

Export/Import for record merge on iPad

Post

     Hello All,

     I have built a client information storage database and, to make the issue very short, am trying to write a script that can merge two records that may have accidentally been created for the same client.  I understand that the best way to do this is to export the record you want to merge, then import the data back into the file in a second temporary table and then compare each field and copy over the fields you want to merge into the duplicate record.  This is working perfectly on my desktop, however when I try to execute the script on the iPad it is not seemingly able to import the records I exported.  My export script uses a variable $$path as the file which looks like:

     "file:" & Get ( TemporaryPath ) & "Merge.mer"

     I then run the import script afterwards using the same variable, and although no errors are thrown (as in the file could not be found), no records are imported into the temporary table.  I have tried with various file types (although I have been lead to believe that since I can't use .fmp files on an iPad, .mer would work just fine) and still no success.  I am at a bit of a loss here since I am not getting any errors on either the export or the import, it simply isn't executing.  I can relatively confidently confirm it is exporting properly, as I get the export dialogue and it executes when I run that script, but I am not even getting a dialogue for the import script, it skips it completely.  Any insight would be greatly appreciated, thanks!

      

Outcomes