1 2 Previous Next 15 Replies Latest reply on Oct 27, 2014 7:24 AM by ScottWalker

    Filemaker Go 13 and iOS 8.1

    j.hall

      Title

      Filemaker Go 13 and iOS 8.1

      Post

      Having an issue with iOS 8.1 and Filemaker Go. 

      We have a process where they select a picture they have taken on the iPad and upload it to the database on the iPad. Since installing 8.1 on Monday, this seems to have stopped working. They can go through the process but it doesn't actually put the file in the database.

      Anyone seeing the same thing?

        • 1. Re: Filemaker Go 13 and iOS 8.1
          schamblee

          I just tested a sample starter solution and insert a photo without any problems.  I have an iPad 3 with 8.1 with Go 13.0.5.  Check security settings for the user.  You may also want to run the script with full access privileges.   If you still have issues, I would create a new sample databases and verify that you get the same results.  If it still fails then please send me a link to the sample db and I will test to see if I get the same results.

          • 2. Re: Filemaker Go 13 and iOS 8.1
            j.hall

            There isn't a script, it's part of the build in add photo on a container. It is also happening independent of the user.

            • 3. Re: Filemaker Go 13 and iOS 8.1
              schamblee

              If the default menu is not appearing then check your security setting also make sure available menu is set to all.  I tested the assets starter solution which doesn't have a script either, and it worked, that is why I thought you might being using a script and got different results.  

              Sorry, I know your menu is appearing but another user has a similar question they just posted.  I would still check security settings and you want default menu available to the client.

              • 4. Re: Filemaker Go 13 and iOS 8.1
                j.hall

                The default menu is appearing and it's going through as if its working, but the picture doesn't show up in the container. It looks like it's working, but the picture never appears.

                There is in varying reports of it crashing filemaker or not. I'm not seeing that on any of my devices. But it isn't uploading the picture for sure.

                • 5. Re: Filemaker Go 13 and iOS 8.1
                  schamblee

                  Have you test another sample database? 

                  I would run "Recover" on the database to make sure the database is not corrupt.

                  Is the container field in a related table?  If so verify that your relationship is correct.

                  • 6. Re: Filemaker Go 13 and iOS 8.1
                    Jade

                    Turn on "FileMaker Go" in the Settings>Privacy list if it is off.

                    • 7. Re: Filemaker Go 13 and iOS 8.1
                      j.hall

                      Few things to keep in mind. 

                      1) This is only occurring on Filemaker 13 and iOS8.1 (Devices that have not been updated to 8.1 and are only running 8.0.2 are functioning normally)

                      2) There are, 60 to 70 users at any given time in the database and it's running 24/7

                      • 8. Re: Filemaker Go 13 and iOS 8.1
                        Jade

                        Keep in mind that 8.1 adds a new Privacy setting to block app access to photos unless you turn each app on in the Settings>Privacy>Photos on each iPad

                        • 9. Re: Filemaker Go 13 and iOS 8.1
                          j.hall

                          They were double checked and it seemed to make no difference. It's only the one iPad that's been updated. I'll update another one tomorrow and see if it preforms in the same way.

                          • 10. Re: Filemaker Go 13 and iOS 8.1
                            j.hall

                            OH: 

                            It is seeing the pictures and allowing you to select them from the iPad. So that would be working I would assume. Like I said. It goes through the entire process normally, but the pictures do no appear in the container.

                            • 11. Re: Filemaker Go 13 and iOS 8.1
                              Jade

                              While you are at it, also turn on "FileMaker Go" in Settings>Privacy>Camera.  I just verified inserting pictures from the camera as well as the photo collections.  Both work on iPad 2; iOS 8.1; FileMaker Go 13.0.5 but this is not hosted by a FileMaker Server.

                              • 12. Re: Filemaker Go 13 and iOS 8.1
                                ScottWalker

                                I am having similar issues with container fields in FileMaker Go 13 and iOS 8.1. When a user taps on the container field, you don't get the normal "import" menu. It just says "Paste" and then if you choose that you get an "Actions" menu (which you would normally see if there was already an image in the container). You can then "Replace" to choose a photo or signature or whatever to insert.

                                I have allowed access to photos in FileMaker Go and I am running as a user with full access, so this is not a permissions issue. Seems to be an iOS 8.1 related bug. Any ideas for workarounds?

                                • 13. Re: Filemaker Go 13 and iOS 8.1
                                  schamblee

                                  Scott.  I have tested this issue on Filemaker Go 13 and iOS8.1 and I received the expected menu.   For something to be ruled a bug, it will have to be reproduced by tech support.  Try a new sample databases, such as one of the starter solutions.  There may be an issue with your file.  I will retest on both my iPhone and iPad.   Is your file locally on the device, or is it being hosted?  If hosted, is it hosted on filemaker server or filemaker?   What version of  filemaker server or filemaker are you using to host?  What version of filemaker was your database created?  

                                  • 14. Re: Filemaker Go 13 and iOS 8.1
                                    TSGal

                                    All:

                                    I have updated to iOS 8.1, and I am unable to replicate the issue with FileMaker Go 13.0v5.  I have tried this locally (using the Assets startup solution), connected to a FileMaker Pro 13.0v3 hosted file with Container fields set for Images and Interactive content, and also connected to FileMaker Server 13.0v4 using the FMServer_Sample file.  I tried with existing and non-existing images.

                                    After the Import window appears, if I tap a second time in the Container field, the Paste option then displays.

                                    When only the Paste option appears, what were you doing just prior?  Do the Container fields have any special options?  For example, do you store the Container data externally?  Is it secure storage?  Open storage?  Any other information you can provide to help me reproduce the issue would be appreciated.

                                    TSGal
                                    FileMaker, Inc.

                                    1 2 Previous Next