6 Replies Latest reply on Mar 5, 2013 8:32 AM by schamblee

    FileMaker Go and Commit Record script step

    DavidWolfe

      Title

      FileMaker Go and Commit Record script step

      Post

           I'm hoping there's a simple solution to this or I'm just misunderstanding things.  This is in regards to Go 12 and FM 12.

           This is primarily affecting an FM Go database but it also seems to be a behavior of the full client.  It seems that if a script trigger (OnObjectSave) is tagged to a field that's a drop-down menu (maybe other formats as well) and the final step of that script is a "Commit Record" FM doesn't exit the field.  It traverses to the next field in the tab order.

           Previously (as my memory serves me), the Commit Record step forced an exit of focus of all fields.  It's become difficult to design a smooth interface when focus unwantingly jumps to the next field causing the virtual keyboard to pop up or a new pop-up menu springs up.

           Is this the expected behavior?  How can I get out of all field focus at the end of a script?

           Thanks in advance!

           David Wolfe
           Fishers, Indiana

        • 1. Re: FileMaker Go and Commit Record script step
          DavidWolfe

               Clarification on the problem.  Download example file with the link at the bottom.

               Simple database.  1 table, 2 fields, 1 script, 1 layout, 1 value list

               Two fields are present on the layout twice.  Top two are Pop-Up fields,   Bottom two are Drop-Down fields.

               All fields have the OnObjectSave trigger set to the "Commit" script which has 1 step: Commit Records.

               All fields are in the tab order, 1 through 4.

          Fat Client behavior:

               When clicking either of the top two Pop-Up fields, works as expected.  Commit takes place and the pop-up dismisses and nothing is in focus.

               When clicking either of the bottom two Drop-Down fields (remember, same Commit script), a virtual TAB keystroke seems to get applied and field focus is forced to the next field in the tab sequence.  Commit does NOT exit field focus.

          FM Go behavior

               When clicking either of the top two Pop-Up fields, field focus to placed in the FIRST tab position.  So, if you click the first field, focus STAYS there.  If you click the second Pop-Up, focus moves to the first field which is the first tab position.

               When clicking either of the Drop-Down fields, focus moves down the tab order to the next field.  Commit does NOT exit any field.

                

               As you can see, designing a controlled data entry interface with these anomalies is impossible.  Focus is jumping without logic.  If I remove all tab stops, behavior on the fat client and Go become the same but still unacceptable.  Clicking the Pop-Up fields works as expected.  Click, Commit, nothing is left in focus.  Clicking the Drop-Down fields results in focus STAYING in the field with the drop-down still expanded causing extra clicks being required to close the drop-down.

               Thanks again for investigation/info on this.

               Download example file: http://www.mpconnection.com/Test.fmp12

          • 2. Re: FileMaker Go and Commit Record script step
            schamblee

                 See this link about OnObjectSave

            http://www.filemaker.com/help/html/script_trigg.38.5.html

                 If you add Exit Script[Result:False]  step, focus will remain in the current field.

            • 3. Re: FileMaker Go and Commit Record script step
              DavidWolfe

                   Thanks for the pointer but I don't believe that applies here.  I have tried an Exit Script [True] but focus continues to traverse to the next tab in sequence when the drop-down fields are modified rather than all field focus being exited with the Commit Records step.

              • 4. Re: FileMaker Go and Commit Record script step
                schamblee

                     Set Exit script to [False] as state above and in the link.   False saves the data but does not advance to the next field. [True] Advance to the next field.

                     How does that not apply?  That is what you said you wanted. 

                     It must be set to false not true. 

                • 5. Re: FileMaker Go and Commit Record script step
                  DavidWolfe

                       S,

                       Thank you for the follow up.  You are correct for fat client behavior.  I did not try false until just now.  That does clear up fat client behavior.

                       On FM Go, there is still an issue.  The drop-downs behave like the fat client does with a false exit but the pop-ups still reset field focus to the first tab stop.  Almost there but with FM Go layouts I tend to use a lot of pop-ups to keep users from accessing the virtual keyboard  as seldom as possible.

                       Thanks again for the extra effort.

                  • 6. Re: FileMaker Go and Commit Record script step
                    schamblee

                         You're correct, the  popup menu / script trigger (OnOjbectSave) doesn't perform as expect in Go. This may be a bug.   You can report this at report an issue at top of this page to have filemaker to take a look.

                         The documentation states focus will remain with the current field if you exit script with false, and it does not in FileMaker Go.

                         There is not a built in way to disable the keyboard in Go.  You can request a feature at the following link.

                    http://www.filemaker.com/company/contact/feature_request.html

                         The only way I know how to disable the virtual keyboard is with a bluetooth keyboard connect and turned on.

                         Good luck.