1 Reply Latest reply on Jan 7, 2011 8:43 AM by mdaracz

    Filemaker Go Import From Local Database To Remote Using Scripts Problem

    mdaracz

      Title

      Filemaker Go Import From Local Database To Remote Using Scripts Problem

      Post

      First some background.  I am currently developing a database for our sales people to be able to place orders for our products using their iphones. To accomplish this I have built local database that are stored on the iphones and a "back end" remote database sitting on a server that they can send the orders to.

      I am having problems implementing a good "sending of orders" solution

      I know that in the current implementation of filemaker there is a limitation for exporting where I can only export the entire database and the email it, I can export field contents, or I can export as pdf.   I have tried to get around this limitation by taking advantage of the instructions provided in the Filemaker GO Database Developer Guide:

      "

      Example 2: Importing from a local source (Source.fp7) into a remote database (Target.fp7)

      1. Transfer Source.fp7 to FileMaker Go.

      2. Open Target.fp7 in FileMaker Pro. 

      3. Create an “Import to Remote” script in Target.fp7. For example:

      Set Variable[$FilePath;Value:Get(DocumentsPath) & “Source.fp7”]

      Import Records[No dialog; “$FilePath”; Add; Mac Roman] where the path to the source file on the device is file:$FilePath

      4. In the Edit Script dialog box, select the Import Records script step and select Specify import order.

      If the source fields do not appear in the Import Field Mapping dialog, select Specify data source, and add another path to Source.fp7 to the path list. For example:

      file:$FilePath

      file:Source.fp7

      5. Open Target.fp7 remotely in FileMaker Go.

      6. Run the script "Import to Remote."

      Using Target.fp7 in FileMaker Go, you have added data from Source.fp7 on the device to Target.fp7 on the host computer."

      So, My problem is as follows:

      I have two scripts to perform the transmission, most of the work is being done on the local database to prepare the order for transmission, then the local script is instructed to open the remote back end database which automatically runs the remote script which imports the records from the local database. As soon as the import is attempted in the remote script, I get error 802  (Unable to open file) which I captured with error function.  

      Heres some facts:

      1. IF, I try to manually open the remote database on the iphone, and run the import script, there is no issues. 

      2. I have made extra sure that I am specifying the right path in the variable for searching for the local database. 

      3. If I have both databases on the servers and try to run my scenario there, I am okay too.

      4. IF, I open the local database on my computer and run my scenario, I have no issues 

      My assumption is that the problem is that if I run the local script on the local database and the scripts calls to open remote database which automatically triggers the remote database import, the local database "locks" somehow and becomes inaccessible. 

      What do you guys and gals thinK? here are my scripts. 

      Local Script. 

      Remote Script.