1 Reply Latest reply on Aug 3, 2015 2:34 PM by schamblee

    FM Go Layout size and zoom

    felixbrabant

      Title

      FM Go Layout size and zoom

      Post

      Hello Filemaker community,

      I manage a project management solution for my company. I'm working on new mobile layouts so our employees can work on the road. I have an issue regarding resizing a layout to match different screen sizes (5, 6, 6 Plus) and preventing users to zoom in the layout. 

      I know that FM Go automatically resizes layouts to fit the screen resolution. To be sure to have the best visual result on all iPhone models, I plan to make my layouts 1080 x 1980 px to fit the iPhone 6 plus. Resizing on my iPhone 5 works A1.

      The problem is that I dont want to user to be able to zoom in or out in the layout. I asked my friend Google, and he suggested me to lock the zoom in a script step. I tried it, but the script step won't let me lock the screen without specifying a zoom level. So when I set the zoom level to 100% and and check the Lock checkbox, the layout is perfect for an iPhone 6 Plus, but way to big for an iPhone 5, 5S or 6. 

      My understanding is that those are my options : 

      A - Users can zoom in and zoom out. Too bad.

      B - Having 3 versions of each mobile layouts, manually adjusted for iPhone 5, 6 and 6 Plus.

      C - Making all layouts for iPhone 5 and assuming that the layouts will be blown and pixelated on iPhone 6 and 6 Plus

      Am I correct? Dose anyone know a way to do what I want? I hate making sacrifices. 

      Thanks a lot

      Felix

       

       

       

       

       

        • 1. Re: FM Go Layout size and zoom
          schamblee

          The best way to handle different size layouts is to design for the small screen size and then use auto sizing on an object to stretch the layout for the larger screen.  

          The easies way to get started is to place a small line in the bottom right hand corner of the layout.  With the line selected go to the inspector click the position tab, then under auto sizing remove the top and left locks and apply the right and bottom lock. Click on the data tab and put a 1 in the Hide object when field, this will case the line to be invisible.  

          You can get a more professional look by adjusting auto sizing on different fields so the field will stretch to.      

          1 of 1 people found this helpful