7 Replies Latest reply on Jul 14, 2014 4:47 PM by TimothyNees

    FMGo12 vs FMgo13

    TimothyNees

      Title

      FMGo12 vs FMgo13

      Post

           I just replaced FMgo12 with FMgo13 on my Ipad and Iphone and now my database which has been functioning properly using FMgo12 will not save or send documents using FMgo13.  I couldn't find anything different in the developers guide regarding saving files as PDF.  What I see happening on the screen when I try to save and send a document using my already proven script steps is a quick flash at the bottom of the screen and then it brings up the mail client with no doc attached.

           This is what I would see if a user typed the company name using an improper symbol such as / in the company name field. (PDF to be created is using Company name field in a calc to name the file being saved).

           Is there any difference in FMgo13 that may be causing this?  PDFpath, Filepath etc.

           The database is written using FileMaker Pro Advanced 12 latest update installed.

        • 1. Re: FMGo12 vs FMgo13
          AppGuy

               If you post your script and we can help you out...

          • 2. Re: FMGo12 vs FMgo13
            TimothyNees

                 This script and the database have been working fine until loading FMgo 13 onto my devices, but here it is anyway. I tried adding pauses but that didn't help.

                 Thanks

            • 3. Re: FMGo12 vs FMgo13
              AppGuy

                   FYI-

                   You don't need the pause's in-between ... Also in my scripts I put .pdf on the end..  $filename; Value:new inspections copy::filename & ".pdf"

                   I can't see from this view but do you have the Attach file and your variable?

                   You also don't need the enter browse mode since you are already there..

                    

              • 4. Re: FMGo12 vs FMgo13
                TimothyNees

                     Thanks Jp

                     The .pdf is built into the calculation which builds the field called filename.  This script has successfully been in use for 2 years now without any incident, I have literally thousands of documents created, saved, and emailed using this script.  the only thing that has changed is I removed FMgo12 from device and added FMgo13 to device.  The description in the app store says FMgo13 is compatible with databases written using FileMaker Pro 12.  again the only thing that has changed is the version of FileMaker Go I'm using.

                • 5. Re: FMGo12 vs FMgo13
                  AppGuy

                       Gotcha..  I have similar scripts that were built in 12 and now in Go 13 working fine...

                       My suggestion would be to break it down... 

                       As a method of troubleshooting try to automatically open the document instead of emailing it..   If this works you know it is getting the PDF..

                        

                  • 6. Re: FMGo12 vs FMgo13
                    schamblee

                         It's a new version so there may be a bug that hasn't been discovered, so as JP stated above you have to go through steps to find where your scripts is failing.  This will help you find out if it is a FileMaker Bug, Scripting error, and or some other change that FileMaker may have made.  

                         If the file is being created then it would have to be Send mail script step.

                         I would bet it has something to do with the file path.  I would make sure the PDF is being created and the file path to the PDF.

                    • 7. Re: FMGo12 vs FMgo13
                      TimothyNees

                           Ok, I broke down the script and tried step by step back and forth between go and Pro.  I got it working, evidently the new version of Go wants $PDFpath at the top of my list of output files.  Moving $PDFpath to the top of my output files list worked, now I hope everything works on Server, I had to rearrange my output files to make things work on Remote Server.  $PDFpath was at the bottom of my output files list and it was working fine with the last version of Go.

                           The only problem with this is its going to save pdf files to the same path as FM when on the PC.  I previously had it saving pdf files to a specific folder when on the PC.