AnsweredAssumed Answered

Graphic Won't Insert via Calc to Container Field

Question asked by illumine on Nov 11, 2014
Latest reply on Nov 12, 2014 by TSGal

Title

Graphic Won't Insert via Calc to Container Field

Post

EDIT: I just navigated my way to the FM Go layout with the repeating container field (the graphics pool, if you will) and can see that the right apple didn't come across when I copied the file from my laptop.  What would cause that kind of failure?

Here's an interesting one.

I have a dozen or so graphics in a repeating container field.  That repeating field serves as the pool for graphics in the DB and provides them when various dynamically operating calc(container) fields call for them.

This all works smooth as silk inside of FileMaker on a laptop/desktop but seems to be hyper-finicky when asked to work in FM Go.  I had trouble a couple of weeks ago getting the left apple (seen in the attached file) to populate a calc container field (all the other graphics in the repeating container field worked just fine) and I tweaked and I tweaked the graphic in every way I could image, and then suddenly, it worked.

Well, here I am again facing the same problem but this time trying to get a modified copy of the very same apple (right graphic in attachment) to insert into the same calc(container) field and finding no joy. crying

Things I've tried with the right apple (Filemaker Pro visibility results / FileMaker Go visibility results):

         
  1. Inserting graphic by drag-and-drop (successfail)
  2.      
  3. Inserting graphic from inside repeating container field by using the "Insert Picture…" command (successfail)
  4.      
  5. Varying aspect ratio of receiving calc(container) field (successfail)
  6.      
  7. Saving graphic in .png and .jpg formats (success both countsfail both counts)
  8.      
  9. Saving graphic from two different graphics applications (1st vector-oriented and 2nd bitmap-oriented) (success both countsfail both counts)
  10.      
  11. Re-naming the graphic (success all counts / fail all counts)
  12.      
  13. Redirecting the calc(container) field to retrieve different graphics known to work from the same repeating container field (success all counts / success all counts)
  14.      
  15. Manually placing the graphic in a test container field on the same layout (successsuccess)
  16.      
  17. Varying the size of the graphic in both graphics applications (success all countsfail all counts)
  18.      
  19. Varying the graphic attributes in the FM Inspector Pallet (success all countsfail all counts)
  20.      
  21. Inserting a completely different graphic captured by means of screenshot and inserted into repeating container field (success / fail)

 

I'm reluctant to spend hours and hours all over again trying to 'hit' that certain unknown combination that eventually got the first apple to work and I was hoping one of you had encountered this sort problem and could provide some some kind of explanation as to what is happening.

Thanks.

FMPA 13.0v3, FM Go v.13.0.5, iPad Air (1.5 months new) running iOS v.8.1

Red_Apple_Works_DosentWork.jpeg

Outcomes