8 Replies Latest reply on Jun 16, 2015 7:25 PM by padaddy

    How to stop Go from automatically capitalizing the first word in a field

    padaddy

      Title

      How to stop Go from automatically capitalizing the first word in a field

      Post

      I am using a field that stores somewhat random looking text.  Perhaps something like "thwUUq".  I mask the text as it is typed (somewhat like you might mask a password).  When typing in Go using the soft-keyboard I've realized that the first letter you type is always capitalized, so rather than getting "thwUUq", you end up with "ThwUUQ".  Because I am masking letters as they are typed you don't realize that the letter has been capitalized.  Is there a way to force Go NOT to capitalize the first letter of a word?

        • 1. Re: How to stop Go from automatically capitalizing the first word in a field
          philmodjunk

          I am chuckling as I type this. In FM GO 13, we all complained because the auto-capitalize behavior typical of data entry in other parts of the iOS did not happen. So FileMaker inc gave us what we requested and now we have a post asking for the opposite....

          If the first letter were always lower case, you could set up an auto-enter calculation that always sets the first letter back to lower case.

          But since you probably want either option, something like OnObjectKeystroke would need to run a script that checked "get ( activeModifierkeys) to see if the shift were "down" or not--if that works the same off a virtual keyboard in iOS as it does in FM GO on a regular computer.

          Unless they gave us some new setting somewhere that allows us to turn the auto-capitalize feature on/off?

          • 2. Re: How to stop Go from automatically capitalizing the first word in a field
            padaddy

            I was wondering why I had only just noticed this behavior- I was pretty certain I didn't have the problem before...

            As I was searching through forums, I noticed people asking for auto-capitalization, and secretly swearing at them under my breath!    If they really NEEDed a capital letter at the beginning of a field, then they could just write a handler for it.  In my case, I may or may not want a capital- but the intuitive behavior is to hit Shift for a capital, not to hit shift to "un-capitalize".  

            I understand iOS normally works this way, and when writing sentences into text fields, it makes sense.  But even when designing iOS apps, we have the ability to determine per field object whether or not we want the capitalization behavior.  I guess that's what I need to go back and ask FM for.  We need a field setting that allows text to be entered without any assumptions about caps. The soft-keyboard does indicate the shift-key as being "down"- but when you have a field where the text could begin with lower OR uppercase letters, it is not intuitive to remember to "un-capitalize" before entering text.  I'll have to look into the activeModifierKeys, I have never really worked with it before.  Thanks.

            • 3. Re: How to stop Go from automatically capitalizing the first word in a field
              schamblee

              Time for a new feature request. A switch to toggle the behavior. http://www.filemaker.com/company/contact/feature_request.html

               I too remember all those post, with user complaining about the first letter not being Auto-Capitalized.

               

              • 4. Re: How to stop Go from automatically capitalizing the first word in a field
                TSGal

                Shannon Sears:

                FileMaker Go 14 now reads the Auto-Capitalization setting in iOS.  To turn off Auto-Capitalization, go into Settings, tap on General, tap on Keyboard, and turn off Auto-Capitalization.

                TSGal
                FileMaker, Inc.

                • 5. Re: How to stop Go from automatically capitalizing the first word in a field
                  padaddy

                  Yes, I know that was the change in 14.  I cannot tell people using my solution to unilaterally turn off their capitalization preferences.  Generally speaking, I'm fine with auto-capitalization- let the user choose how they want to use their device.  But there are fields where I need exactly what is typed, without any assumptions (regardless of where filemaker reads it's auto-cap setting from).  Case in point, I have one layout where there are several text fields.  Most would be fine with auto-capitalization, in fact it is probably welcome in the comments text field.  But I have two fields where a lot and serial number need to be entered.  These are case-sensitive fields, and no user expects to have to "un-capitalize" if the first letter is lower-case.  I design apps in Objective C, and this is certainly something we are able to set per field.  I would like the same option in FMGo, FM needs to give us the choice to use auto-caps at the field level, or at minimum at the application level.  As it is, I am reverting back to Go 13. 

                  • 6. Re: How to stop Go from automatically capitalizing the first word in a field
                    TSGal

                    Shannon Sears:

                    Thank you for your comments.  I have submitted this feature request to Development and Product Management for consideration in a future release.

                    TSGal
                    FileMaker, Inc.

                    • 7. Re: How to stop Go from automatically capitalizing the first word in a field
                      philmodjunk

                      In the meantime, it might be worth experimenting with OnObjectKeystroke, using Get ( TriggerModifierKeys ) to detect whether or not the shift or capslock is down.

                      Something like:

                      If [Length (yourTable::Field ) = 1 //first character input ]
                         If [ Get ( TriggerModifierKeys ) = 0 // no shift or caps lock...]
                             Set Field [ YourTable::Field ; lower ( YourTable::Field ) ]
                             Exit Script [false]
                         End If
                      End If

                      • 8. Re: How to stop Go from automatically capitalizing the first word in a field
                        padaddy

                        I tried using triggerModKeys/activeModKeys after you first suggested it.  But unfortunately those do not work on iOS keyboards.  :(