5 Replies Latest reply on Dec 5, 2014 9:05 AM by TSGal

    prohibit modification not working

    JonathanMarcus_1

      Title

      prohibit modification not working

      Post

      I have a field that is set to prohibit modification. It works correctly in FMP, but on FM Go, it allows modification. Is this a compatibility issue with FM Go?

        • 1. Re: prohibit modification not working
          TSGal

          Jonathan Marcus:

          Thank you for your post.

          What type of field?  Text?  Container?

          Is the modification done through a script or manually?

          Is a specific user privilege controlling the modification?  Is the field behavior unchecked for Browse in Inspector?

          Did this work previously?  If so, what has changed?

          Any other information you can provide may help narrow down the possible causes.

          TSGal
          FileMaker, Inc.

          • 2. Re: prohibit modification not working
            JonathanMarcus_1

            Thanks for the quick reply.

            What type of field?  Text?  Container?

            It is a text field.  It contains a value list, but the problem existed when I tested it as a normal text field.

            Is the modification done through a script or manually?

            Modification is done manually.

            Is a specific user privilege controlling the modification?  Is the field behavior unchecked for Browse in Inspector?

            User privilege is "full access"

            Did this work previously?  If so, what has changed?

            This is not applicable.  Originally it was set without restriction, but users were inadvertently making changes. Change was made to prevent this.  Another work around was to change user access to limit modification of this field, which works fine.  But for future reference of other fields needing mod restrictions, I am still curious as to why it worked previously on FM pro and not on fm go?

             

             

            • 3. Re: prohibit modification not working
              TSGal

              Jonathan Marcus:

              Thank you for your post.

              With the information available, I don't know why this did not work in FileMaker Go.  Just to be sure, I created a file with one Text field, with the Auto-Enter option "Prohibit modification of value during data entry" checked, and the field formatted as a drop-down list (3 values) as well as edit box, and the only way I can enter data is through a script (Set Field).

              Setting the field to be inaccessible in Browse via Inspector "Data -> Field Entry" also worked properly on both Desktop and iOS device.

              Are you using FileMaker Pro 12 with FileMaker Go 13?

              Let me know if you can narrow down the options further and find the cause.

              TSGal
              FileMaker, Inc.

              • 4. Re: prohibit modification not working
                JonathanMarcus_1

                Ok, so I set everything back. And this time it worked correctly.  Obviously, I must have done something wrong. I apologize. But thank you again for your time.

                • 5. Re: prohibit modification not working
                  TSGal

                  Jonathan Marcus:

                  You may not have done anything wrong.  If you run into this issue again, please let me know.

                  TSGal
                  FileMaker, Inc.