2 Replies Latest reply on Feb 27, 2013 1:09 PM by netguykb

    Script Error, Works on Desktop but not on iPad

    netguykb

      Title

      Script Error, Works on Desktop but not on iPad

      Post

            

           First Problem: I have created a script for importing a bunch of records from one table to another. This process is done by first creating a new record in my main table: “Vendor” After doing so I then run the script below. On my desktop it works correctly with the exception that if I run the script twice then twice as many records will appear in the table Not Good

           First Questions: How can I prevent or check to see if the files already exist? Currently the link that allows a user to tun the script is some text with some conditional logic that changes the text of the link to match the background after the script has been executed. This works but is not full proof in the event they inadvertently click on it again.

           Second Problem:  I have copied the db to my iPad and have tried executing the script HOWEVER a huge flaw occurs. It somehow deletes all but one record in the related reference table x_vendor_component_function and updates it appearing that the data now is associated to the newly created Vendor record. All other data gets deleted.

           Second Question: How do I prevent this from happening specifically on the iPad?

           Any help would help, and thank you!