1 Reply Latest reply on Apr 15, 2010 12:40 PM by TSGal

    Admin console cannot validate certificate

    mattwatts

      Title

      Admin console cannot validate certificate

      Your post

      Whenever I try to launch Admin Console on a remote machine (ie not the machine running the server) I get an error message saying that Java 'Failed to validate certificate'. I'm given two options 'Details' and 'OK'. If I choose OK, the console then quits. 'Details' gives the following message:

       

      java.security.cert.CertificateException: Unable to evaluate certificates at com.sun.deploy.security.MacOSXTrustUI.evaluateTrustAndShow(MacOSXTrustUI.java:147) at com.sun.deploy.security.MacOSXTrustUI.showDialog(MacOSXTrustUI.java:47) at com.sun.deploy.security.X509Util.showSecurityDialog(X509Util.java:152) at com.sun.deploy.security.TrustDecider.isAllPermissionGranted(TrustDecider.java:663) at com.sun.javaws.security.AppPolicy.grantUnrestrictedAccess(AppPolicy.java:264) at com.sun.javaws.LaunchDownload.checkSignedResourcesHelper(LaunchDownload.java:1460) at com.sun.javaws.LaunchDownload.checkSignedResources(LaunchDownload.java:1170) at com.sun.javaws.Launcher.prepareLaunchFile(Launcher.java:1020) at com.sun.javaws.Launcher.prepareToLaunch(Launcher.java:306) at com.sun.javaws.Launcher.prepareToLaunch(Launcher.java:183) at com.sun.javaws.Launcher.launch(Launcher.java:104) at com.sun.javaws.Main.launchApp(Main.java:405) at com.sun.javaws.Main.continueInSecureThread(Main.java:252) at com.sun.javaws.Main$1.run(Main.java:111) at java.lang.Thread.run(Thread.java:637)

       

       

      I've tried clearing the Java cache and checked that ports 16000 and 16001 are open on the server machine.

       

      I can launch Admin Console on the server itself without any problems, just not on a remote machine. Any suggestions?

       

      Server: FMSA 11.0.1.95 on Mac OS X 10.5.8

      Client: Mac OS X 10.6.2 

        • 1. Re: Admin console cannot validate certificate
          TSGal

          MWatts:

           

          Thank you for your post.

           

          I would first try opening all ports on the server.  Try launching Admin Console again.  If this fails, then change your firewall settings (if they exist) to allow all incoming connections and try again.  If this fails, then make sure the admin_console_webstart.jnlp file is set to launch with /System/Library/CoreServices/Java Web Start.

           

          Please let everyone know if this issue was resolved and what was the cause.

           

          TSGal

          FileMaker, Inc.