AnsweredAssumed Answered

As soon as a database is hosted on my server, users can't modify any records

Question asked by carinahulselmans on Aug 6, 2015
Latest reply on Aug 7, 2015 by disabled_ntaylor

Title

As soon as a database is hosted on my server, users can't modify any records

Your post

Hello filemaker users,

 

I'm using Filemaker pro advanced 13 and filemaker Server 13. I've set everything up succesfully and I now have my 2 databases hosted on my server and accessible from outside the network. YAY!

 

It worked 100% as intended before, I hosted one database on the server and was able to succesfully access it from inside and outside the network. Users were automatically able to access/edit records and do everything I could do before I felt the need of a server.

Then I tried adding an additional database to the server, to do that I turned off and on the server, and now suddenly BOTH databases are now allowed to edit by any users, acting as if the user's priviliges are set to read only (no scripts,buttons,text fields, settings etc work).

I've tried :

         
  • Closing the server and going into the database file directly, removing all users except for guest, setting guest to all priviliges.
  •      
  • Checking in Filemaker Server -> Activity -> Clients if the user has full privileges . Yes he does, (proof : https://gyazo.com/b8af24c1af8be389ecd9ee66dc5dbac5)

I'm not sure what else could be going wrong , the error message is :

https://gyazo.com/ae43e1eb868580b4fac2c8954c1c9d70

Which roughly translates to :

This action can not be done because this file can not be edited.

I'm not sure how I can give you more information to be able to narrow down my problem and potentially help me out. Please respond with any advice you could have, or any questions to narrow down my problem even more.

Thanks for reading,

 

Boyen / Carina

 

Outcomes