8 Replies Latest reply on Oct 21, 2010 7:28 AM by AndrewsMurphy

    Backup Path Not Valid

    Gregx

      Title

      Backup Path Not Valid

      Your post

       

       I am Running FM Server 9 . Since upgrading the OS  to  Leopard  Server the Filemaker  schedule backup  seems to be limited to this path " filemac:/Boot/Library/FileMaker Server/Data/Backups/" If I add one more folder to the end of the path it becomes invalid, or  the path is valid but the Run status for the backup  says "permission denied"   

      In OS10.4 I solved the problem my resetting the access permissions to the specific backup folders, but that is not working with Leopard.

      Current permissions for FM server Data and Backup folders  are fmserver R/W and fmsadmin R/W . I have reset permissions on these folders several times with no luck. Am I stuck with this backup path? Is there a way to add to it?  Any help would be much appreciated.                                                                                                                             Thanks                                                                                            Gregx

        • 1. Re: Backup Path Not Valid
          rmanook

          Hi Gregx,

          Thanks for posting.

           

          To verify, are you adding the '/' character at the end of the path?

           

          You will not necessarily need to use that particular path; you can set up a folder on another drive or location so long as that location is not an external drive.

           

          Let me know how it works out.

          Thanks,

          tsturtle

          FileMaker, Inc. 

          • 2. Re: Backup Path Not Valid
            Gregx
              

             

            Yes, I am using the / at the end  . This path is valid and backup runs okay:  filemac:/Boot/Library/FileMaker Server/Data/Backups/. This path shows as valid but permission is denied when it is run:  filemac:/Boot/Library/FileMaker Server/Data/Backups/Daily/ . My guess is it's a permission issue for the added " Daily" folder but resetting the permission on this "Daily" folder has no effect. Current permissions  Admin (owner) R/W   -  fmsadmin (Group) R/W -  (Everyone ) No Access

            • 3. Re: Backup Path Not Valid
              VinceDolan
                

              Greg

               

              Set your permissions to:

               

              fmserver (owner) R/W   -  fmsadmin (Group) R/W -  (Everyone ) No Access or Read only

               

              This is how our is setup, it didn't work until it was.

               

              Vince Dolan 

              • 4. Re: Backup Path Not Valid
                Gregx
                   Thanks for the help Vince.

                  Problem is "FMserver" does not show up in the list of choices in the "select a new user or group" window. Where could it be? Funny thing, the main backup folder has a the default setting of "fmserver" as owner. 

                How do you make fmserver the owner in a new folder?                                                     Thanks for your time         Greg

                • 5. Re: Backup Path Not Valid
                  rmanook

                  Hi Gregx,

                  We had a similar issue posted on the forum.  Here is the response I gave concerning the changing of the Owners of a folder on Mac Leopard:

                   

                  I've added an example of how to add these accounts to your default folder.  Before we get started we'll assume the following:

                  1.  FileMaker Server is installed

                  2.  A New Folder has been created and placed in the root directory of the Mac HD (for this example)

                   

                  Ctrl + Click the New Folder.  From the menu that appears, select the 'Get Info' option and the New Folder Info window will launch.  Next, Expand 'Sharing & Permissions.'  We now get a list of Names (Accounts) and their assigned Privileges.

                   

                  Click on the 'lock' icon at the lower right of the window.  You will be prompted to enter a username/password for an Admin account to verify that we are allowed to make changes to this folder.  Click on the plus sign or '+' icon located at the bottom left corner.  This will allow us to add new accounts to this specific folder.

                   

                  A new window appears and you can choose the fmsadmin or fmserver account.  Select one and then click on the '+' icon again to add the other.  Once these accounts are added, change their Privileges to 'Read & Write.'  You can now close the New Folder Info window by clicking on the red 'x' located at the top left corner (these changes will save automatically).

                   

                  In the Admin Console > Database Server > Default Folders tab, our additional database path will look like this:

                  filemac:/Mac HD/New Folder/

                   

                  Click on validate and we should be good to go!  I just set the folder in the root level of the Mac HD to create a basic example.  As long as you follow the tips you posted earlier and the fmsadmin and fmserver accounts are set, you shouldn't ( hopefully  ) run into any other issues.

                   

                   Let me know if you need any further clarification.  Hope this helps!

                   

                  tsturtle

                  FileMaker, Inc.  

                  • 6. Re: Backup Path Not Valid
                    Gregx
                      

                     

                    Greetings tsturtle                                                                                                                                                                                      The problem begins at this point                                                            

                    "A new window appears and you can choose the fmsadmin or fmserver account. Select one and then click on the '+' icon again to add the other. Once these accounts are added, change their Privileges to 'Read & Write.' You can now close the New Folder Info window by clicking on the red 'x' located at the top left corner (these changes will save automatically)."

                     
                    The fmsadmin nor the fmserver accounts appear when I click the + icon.  The only accounts that appear are the users/groups I set up for the OSX Server. fmsadmin and fmserver are knowhere to be found.                       

                     

                     



                    • 7. Re: Backup Path Not Valid
                      rmanook

                      Gregx wrote:
                        

                       

                      Greetings tsturtle                                                                                                                                                                                      The problem begins at this point                                                            

                      "A new window appears and you can choose the fmsadmin or fmserver account. Select one and then click on the '+' icon again to add the other. Once these accounts are added, change their Privileges to 'Read & Write.' You can now close the New Folder Info window by clicking on the red 'x' located at the top left corner (these changes will save automatically)."

                       
                      The fmsadmin nor the fmserver accounts appear when I click the + icon.  The only accounts that appear are the users/groups I set up for the OSX Server. fmsadmin and fmserver are knowhere to be found.                       

                       

                       


                      ack!
                      I'm sorry, Gregx, I knew that was your issue.  I actually meant to copy and paste my follow-up reply.
                      Here are the steps to add the owner/group via Terminal:

                      Let's try adding the fmserver and fmsadmin accounts via Terminal.  Launch Terminal and then enter the following commands:

                      sudo chown fmserver <database folder path>

                      sudo chgrp fmsadmin <database folder path>

                       

                      You may be prompted to provide the password for the Admin account that you are logged in with.  Also, as a note, instead of typing out the database folder path, you can simply drag the folder into Terminal and Terminal will add the path for you.

                       

                      Since the fmserver and fmsadmin accounts exist on your Library folder, I believe we should be good to go if we take this route.

                       

                      Let me know if you need any further clarification.

                       

                      Thanks!

                      tsturtle

                      FileMaker, Inc.  

                       

                      • 8. Re: Backup Path Not Valid
                        AndrewsMurphy

                        There is a trick to creating a Valid Path for Backup Schedule.  FileMaker Pro Server 11

                        I put an extra space in the file path and it validated the path.  

                        filemac:/External Backup/ Backups/

                        Versus

                        filemac:/External Backup/Backups/

                        Sometimes it matters, other times it does not.  

                        Another recent event that we encountered was using a Filemaker Pro Server on a File Server.  It seems that once File Sharing is enabled through the Server Admin, the Server Admin assumes all responsibilities for administering the permissions.  We could not change the permissions outside of the Server Admin File Sharing preferences.  We could unlock the privileges from Get Info however, we could not add any users through that dialog box.  

                        Changing any privileges within the directories used by filemaker pro server or the system folder can corrupt your system.  

                        Andy