7 Replies Latest reply on Jun 14, 2012 7:37 AM by maser

    Can not enable IWP with FMS 12 on Mac OSX 10.7.3 server

    maser

      Title

      Can not enable IWP with FMS 12 on Mac OSX 10.7.3 server

      Your post

      Mac OSX 10.7.3 Server as the hosting platform for FMS.   FileMaker Server 11.0.4 was working fine with IWP turned on.

       

      I uninstalled FMS 11 and restarted.

       

      I installed FMS 12 -- did not enable ODBC or Web Publishing at that time.

       

      I confirmed that I could open the test database via the FMP 12 client without issue.

       

      I went to turn on IWP for the server (as I was running IWP with FMS 11 on the same server, this is what I want to test here)

       

      Upon "Editing Server Deployment" and enabling web publishing, IWP, Single Machine and the default Apache, I got "Web Server Test Failed" and had to Skip this step and configure later.

       

      According to deployment.log, I have this:

       

      Deployment started at 5/2/12 3:09 PM

      ---------------------------------

      SETUP: PRECONFIGURE WEB SERVER

       

      Stop web server                                             succeeded

      Back up apache configuration file                           succeeded

      Create FMI virtual directory configuration file             succeeded

      Add FMI config file to apache httpd.conf: /Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/fmi-test.conf succeeded

      Disable line in httpd.conf: AddDefaultCharset               succeeded

      Disable line in httpd.conf: LoadModule info_module          succeeded

      Disable line in httpd.conf: LoadModule status_module        succeeded

      Disable line in httpd.conf: AddModule mod_info.c            succeeded

      Disable line in httpd.conf: AddModule mod_status.c          succeeded

      Disable line in httpd.conf: <Location /server-status>       succeeded

      Disable line in httpd.conf: <Location /server-info>         succeeded

      Add FMI status config file to apache config file            succeeded

      Test web server (http://<serverIPaddress>:80/fmi-test/test.xml) sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

       

      START DEPLOYMENT

       

      Step 1: Save settings:

      Save administrative configuration settings                  succeeded

      Step 2: Configure Web Publishing Engine (WPE):

      Stop WPE                                                    succeeded

      Set WPE AutoStart to enabled                                succeeded

      Add JVM Route to JWPC Server XML file                       succeeded

      Create WPC prefs file                                       succeeded

      Create CWPC prefs file                                      succeeded

      Update JWPC prefs file                                      succeeded

      Start WPE                                                   Error: 10006

      Update WPE deployment configuration                         succeeded

      Update mDNS service info                                    succeeded

      Step 3: Configure Database server (DBS):

      Set WPE Authorization Info                                  succeeded

      Set XDBC AutoStart to no                                    succeeded

      Update XDBC deployment configuration                        succeeded

      Update WPE deployment configuration                         succeeded

      Step 4: Configure AdminServer:

      Save WPE deployment settings                                succeeded

      Save DBS deployment settings                                succeeded

      Start WPE                                                   succeeded

      Reindex log files                                           succeeded

       

      Deployment completed at 5/2/12 3:11 PM

      spy:logs root# 

       

       

       

      Now what?    I do run a self-signed certificate for the web services of my OSX Server (wiki, etc.) that continues to work without issue.