7 Replies Latest reply on Sep 22, 2014 7:55 AM by JoachimGrüninger

    Can't login to FMS database on new Mac, other Macs can

    gnat

      Title

      Can't login to FMS database on new Mac, other Macs can

      Your post

      I've found some previous posts regarding this, but still can't solve the problem.  Please bear with me as I'm not fluent with the terminology here and there.

      The server is FMS 9.0.3.325, running on a Mac-mini OS 10.5  I'm trying to access the server using FMP 9.ov3, running on an iMac with OS 10.6.  I just set up this new iMac, installed FMP 9.  When I go into Open Remote File dialog box, it sees the host "host-name-here(192.168...etc)".  When I click on this, nothing appears in the Available Files box. 

      I should say that 5 other Mac computers, even an older G4 iMac, all can access the host as well as the database files, which appear in the Available Files box.

      On this iMac that can't log on, in FileMaker Network Settings dialog box, I have Network Sharing turned on.

      I read about a server.pem file that can be the culprit for such problems, either missing or corrupted, but it seemed limited to Windows. I searched for such a file on other Macs that are connecting to the database and found no such file.

      Please help me troubleshoot this. Thanks.

        • 1. Re: Can't login to FMS database on new Mac, other Macs can

          gnat:

          Thanks for posting.

          This does sound like a server.pem issue. You can find the server.pem file on OS X by right clicking (or CTRL + clicking) on the FileMaker Pro.app file within /Applications/FileMaker Pro 9/ and choosing Show Package Contents. This will bring up a new Finder window where you can navigate through /Contents/MacOS/ to find the server.pem file.

          Let me know if you run into any trouble replacing the non-working installation's server.pem file with a working one.

          TSBear

          FileMaker, Inc.

          • 2. Re: Can't login to FMS database on new Mac, other Macs can
            gnat

            I bow down to thee. It worked! I didn't know about finding files in an application's Show Package Contents option.

            In case it helps anyone else, perhaps the FileMaker team, there was a server.pem file in there, but it had zero KB file size.  I copied another server.pem file from a working computer, which had 8 KB file size, and swapped it in.  Now all is good.

            Thanks again.

            nathan

            • 3. Re: Can't login to FMS database on new Mac, other Macs can
              wkien

              Hi TSBear,

              The server.pem file doesn't resolve my issue.

              Mine FMS 8.0.4 on 10.4.11 Mac OS X Client

              My new iMac is 10.6.7 running FMP 9.

              I connect to the FMS8 database.

              Please help. Thxs

              • 4. Re: Can't login to FMS database on new Mac, other Macs can

                wkien:

                Are any other clients able to access the database?

                If FileMaker Server 8 is set to encrypt connections using SSL, you may want to apply the SSL update for FileMaker Pro 9 available here:

                http://help.filemaker.com/app/answers/detail/a_id/7016

                http://help.filemaker.com/app/answers/detail/a_id/7016TSBear

                FileMaker, Inc.

                • 5. Re: Can't login to FMS database on new Mac, other Macs can
                  MarjiRoy

                  Not an answer but I am experiencing a similar issue to the one noted in this thread.

                  Issue:

                  2 MacBook Pro Laptops can no longer access the Filemaker Pro9 Server.

                  Can launch FilemakerPro

                  Select Remote.

                  In Open Remote dialog Box select local Hosts.  Our server appears in left Hosts box.  Select it.

                  Nothing appears in right Available files box. We have about 10 different databases and none appear. 

                   

                  Specifications:

                  Server Running Mac OS 10.5.8

                  Filemaker Server version 9.0.3.326

                   

                  1 Computer running system 10.6.6 can no longer access the fmp server

                  Filemaker Pro Advanced 9.0v3

                  Computer is a MacBook Pro

                  It worked previously on this computer.

                  Noted the Filemaker Pro was blocked in firewall and allowed it

                  Can access FMP files stored on local hard drive.

                   

                  1 computer running system 10.6.7 (new) cannot access the fmp server

                  Filemaker Pro 9.0.v3

                  Computer is a new MacBook Pro

                  Computer firewall is not activated

                   

                  The 2 computers affected are the only 2 Macbook Pro’s we have with FMP installed.  We have it installed on many other types of Macs and it is working fine. They also both leave the building and log onto various other networks.

                   

                  Many other Computers running 10.5.8 and 10.6.6 with FMP 9.0v3 work fine.

                   

                  Actions taken so far (all on the 1 MacBook Pro with 10.6.6 installed):

                  I have taken the server.pem file from a working Mac and replaced the server.pem file in the non-connecting Mac.

                  I have run the 9.0 SSL updater on the computer as well.

                  I have tried accessing via a wired connection instead of wireless

                  I have reinstall Filemaker Pro on the laptop 

                  The problem persists.

                  Any help would be appreciated.

                  Thanks-MRoy

                  • 6. Re: Can't login to FMS database on new Mac, other Macs can
                    presto

                    After searching for threads with similar configurations, etc., this one seemed to describe my circumstances most closely. My issue was finally resolved when I discovered that my anti-virus software was blocking communication with the host.

                    iMac OSX 10.6.8, FileMaker Pro Advanced 11.0v3 client, FileMaker Server 11.0.3.309 running on iMac OSX 10.6.8, VirusBarrier X6 ver 10.6.12

                    I believe this is what may have happened. Trying to enable remote admin from my client computer,  in the Remote Admin tab of FMS Admin Console, I had checked the box to enable access restriction and entered my client IP address. This did not fix or allow remote admin, so unchecked the box. (I believe my problem may actually be associated with java scripts.) Shortly after this, my client computer could see the host (FMS server), but not the database files.

                    I tried the server.pem replacement, but not a fix. I reinstalled FileMaker Pro Advanced client, but not a fix. However, as recommended, I turned off virus protection while reinstalling FM and didn't reboot before launching FM client (therefore virus protection was still off). Now I could see hosted files.

                    Opened VirusBarrier X6 and while checking settings under "Antivandal" button within the "Blocked Addresses" there it was - the FMServer IP address was listed with this note: "This address was put in the Blocked Addresses list because it tried to run a Port Scan on your computer." I unchecked the blocked address listing and my client then saw hosted files. I unchecked (unblocked) the address, turned on virus protection, launched FM client, and could now see hosted files.

                    Thanks, Marji, for your detailed post. It got me to investigate further and finally fix my problem. Circumstances are never the same, but perhaps others have similar configurations and experiences.

                    HTH, Dick

                    • 7. Re: Can't login to FMS database on new Mac, other Macs can
                      JoachimGrüninger

                      I'm having the same problem, I'm running FM11 on a mac Mini with 10.9.x (up to date) - Two databases (addresses and expenses) are hosted on an Apple G5 Server (our Fileserver) simply from a Filemaker 8.5 client license (we have 2-3 computers connecting so the solution is powerful enough) . I tried to follow an advice to set back the clock before 22nd sept 2008 - then install FM11 - then set the clock to tos´day again (source: http://help.filemaker.com/app/answers/detail/a_id/6995 ) I also tried various tips from the web, claiming I should delete or replace the server.pem and/or root.pem file from the package contents of the Filemaker client app). Fo me none of those worked...  :-(   If anybody has a hint (or maybe a true step ny step instruction) either my situation is note f**ked up than others or maybe I'm overlooking something. Did you have to repair permissions ? delete any prefs or so ? reboot at one or multiple points in the process ? 

                       
                      any help is appreciated Jo