6 Replies Latest reply on Aug 4, 2010 3:00 AM by KarstenRisseeuw

    Can't open database in Filemaker Server 11 Advanced

    KarstenRisseeuw

      Title

      Can't open database in Filemaker Server 11 Advanced

      Your post

      Hello

      I have problems opening databases in Filemaker Server 11. This problem is new as it worked perfect until last week. I have read through all posts I could find on the topic, but none of the suggestions worked so far.

      Configuration: XServe, MacOSX 10.6, Filemaker Server Advanced 11

      Problems occured after remotely installing an update for the XServe. The machine could not restart properly. I had to restart several times, after which the XServe was working normal again. However, the FM Server application did not properly work any longer. All databases were closed and could not be opened.

      I deinstalled FMServer, then reinstalled. Installation was smooth. Ports were still open.

      When re-adding databases using the upload helper application, the databases appeared in the list, but all with an error message, telling that the database could not be opened. This counts for all files. Sharing for all files has been activated for all users. File access is for fmsadmin, fmserver and everyone (both read&write). Nevertheless no file can be opened on the server through the Admin Console.

      Any idea how this can be solved?

        • 1. Re: Can't open database in Filemaker Server 11 Advanced

          Karsten Risseeuw:

          Thank you for posting.

          When FileMaker Server is unable to open a file it usually indicates an issue with the files or with the installation. To eliminate the possibility that the problem is with the database files, try opening them locally with FileMaker Pro.

          After uninstalling FileMaker Server, be sure to remove the FileMaker Server folder prior to reinstalling.  This folder may contain old files that may not be updated during a reinstall.

          Another possibility is that the system update either did not complete properly or it introduced a new incompatible element to the server.

          The Event.log file should provide more information regarding file access. Please check this file in your FileMaker Server > Logs folder or send it to us so that we may. This file should have entries for each database that is opened or closed. Look for errors or warnings near the times when FileMaker Server is starting.

          I have sent you a private message with instructions for sending a file. Please check your Inbox from the link at the top of the page.

          TSuki
          FileMaker, Inc.

          • 2. Re: Can't open database in Filemaker Server 11 Advanced
            KarstenRisseeuw

            Hi TSuki

            Thank you for your help.

            This is what I did following your post:
            - deinstalled Filemaker Server Advanced 11.02.217
            - cleaned all Servercaches with MacOSX Coctail
            - deleted Filemaker Server folder
            - restarted Mac-server
            - reinstalled Filemaker Server
            - no further tuning, just standard.
            - I cannot open the sample file (same problem as before)

            The logfile reads that the temporary file cannot be created.
            (Event-Log in german.)

            Fehler    626    server    Temporärdatei für Datenbank "FMServer_Sample" konnte nicht erstellt werden.

            I have never had this problem before and I'm clueless as where to look for a solution. Any ideas how to cope with this?

            • 3. Re: Can't open database in Filemaker Server 11 Advanced
              KarstenRisseeuw

              One more remark following your post and suggestions:

              - All files could be opened locally
              - In the current "pristine" installation, the same problem occurs with the standard sample file.

              • 4. Re: Can't open database in Filemaker Server 11 Advanced
                PatrickRue

                I'm having essentially the same issue at Karsten (not being able to open a database file, getting the 626 error).  I believe my issue is related to permissions of where this temporary file is being written. I recently had an issue with permissions (accidentally propagated permissions throughout the hard drive rather than just one directory I was intending), and my MacOS X Server wouldn't startup.  I ran Disk Utility from the recovery CD to repair the permissions, which fixed the issue, except my Filemaker databases would no longer open.  After a reinstallation and a thorough check of the permissions in the /Library/Filemaker Server/ directory, I'm stumped.

                Does anyone know where this temporary file is being written?  Perhaps it is outside of /Library/Filemaker Server/ ?

                Thanks,

                Patrick

                • 5. Re: Can't open database in Filemaker Server 11 Advanced

                  Karsten Risseeuw:

                  If the issue occurs even after a clean reinstall, it's likely there is a preferences or configuration issue with the operating system. FileMaker Server creates many temporary files and it's possible that it has lost the permissions to do so.

                  Repairing the permissions with Disk Utility would be a good step to try first. You may need to contact Apple for further permissions troubleshooting.

                  Patrick Rue:

                  Some places where FMS creates a temporary file for each database are:

                  /private/var/folders/

                  /private/var/tmp/

                  It's possible to see precisely which files FMS uses by using a terminal command such as:
                  sudo lsof | grep fmserver | grep REG | less

                  I have sent a private message containing the sample output of this command. By comparing this output with your own, it should be possible to determine which temporary files are not being created.

                  I am able to trigger the 626 error by purposefully removing write permissions from the /private/var/tmp/ directory. Please check that all users have full read/write access to this directory.

                  TSuki
                  FileMaker, Inc.

                  • 6. Re: Can't open database in Filemaker Server 11 Advanced
                    KarstenRisseeuw

                    TSuki – you made my day.

                    The problem could not be solved with the Disk Utility. Enhancing the permissions for the mentioned folders /private/... however did the trick. Everything is running smoothly now.

                    Thanx for your help :-)
                    Karsten

                    Note for future readers:
                    The /private/... folders are invisible. Activate visibility with the terminal or tools like Cocktail http://www.maintain.se/cocktail/download.php