2 Replies Latest reply on Feb 17, 2009 3:19 PM by allotrope

    Can't remove XML access to a file

    allotrope

      Title

      Can't remove XML access to a file

      Your post

      Here's a strange one, we have a solution that contains 5 files and two of the files have XML access and they seem to work properly. I added XML access to a third file via a Privilege set and it worked as expected but then I decided to change the process and eliminate the need for this file to be web accesible. Instead of deactivating the XML privilege I simply deleted the account and Privilege set associated with the XML access assuming that the deletion would remove the access. It didn't, and now I can't seem to find a way to remove XML access. I tried recreating the account and setting then removing the access as well as restarting the web engine and database  server... all to no avail. Any suggestions as to how to remove the XML access from this file?

        • 1. Re: Can't remove XML access to a file
          rmanook

          Hi allotrope,

          Thanks for posting.

           

          In the Manage > Accounts & Privileges > Extended Privileges tab, highlight the fmxml Access via XML Web Publishing - FMS only privilege and click on the Edit button.  Uncheck each box here and then close out.

           

          Hope this helps

          Thanks,

          tsturtle

          FileMaker, inc. 

          • 2. Re: Can't remove XML access to a file
            allotrope
              

            Hi TS,

             

            That's the problem, there is no check beside the XML Web publishing. Please see below:

             

             

             

             

            As you can see, there are no check boxes with an x in it yet the file is being shared via XML which confirmed with the data returned from a fmresultset.xml?-dbnames query on the site:

             

            </metadata>

            <resultset count="3" fetch-size="3">

            <record mod-id="0" record-id="0">

            <field name="DATABASE_NAME">
            <data>Lung_CRM</data>
            </field>
            </record>

            <record mod-id="0" record-id="0">

            <field name="DATABASE_NAME">
            <data>Lung_Labels</data>
            </field>
            </record>

            <record mod-id="0" record-id="0">

            <field name="DATABASE_NAME">
            <data>Lung_webmodule</data>