13 Replies Latest reply on Jun 25, 2010 6:45 PM by Pam3000

    Can't restore backup database in FM Server 8.0

    Pam3000

      Title

      Can't restore backup database in FM Server 8.0

      Your post

      FM Server 8.0 on a Mac OS 10.4:

       

      After a brief power failure, we are no longer able to remotely access our FM database from PC or Mac.  We assume the file has been corrupted since the database status is displaying "closed" and will not open.  We've tried rebooting the system, but that did not work.  We also tried replacing the corrupted file with the most recent backup file, but this did not work either.  How should we proceed to recover our database? 

       

      Intermediate Mac and PC knowledge, limited FM knowledge (we used to have a "guy" who took care of any FM problems we experienced, so we're not as knowledgeable as we should be.)

       

      Thanks!

        • 1. Re: Can't restore backup database in FM Server 8.0
          philmodjunk

          First move a copy of the file to a machine that has filemaker pro installed.

           

          Try to open the file with filemaker pro.

          If you can't open it with filemaker pro, use recover to recover the file.

          Put the recovered file up on the server and see if it will open.

          If so, your file is damaged. If possible, find an older copy, use save a copy as to save a clone of it and import the records from your recovered file into this clone. Put this copy back up on your server.

           

          If the did not need to be recovered, there's a problem with your server. You'll need to check to see if the system is healthy. (Is the hard drive OK?) and you may need to re-install either filemaker server and/or the Operating System.

          • 2. Re: Can't restore backup database in FM Server 8.0
            Pam3000

            Oh boy, I might have made things worse.  I could tell there was something wrong with the database since it was only 17MG in size compared to the most recent backup file which is 88MG.  I thought it might work if I just renamed the backup file and replaced the corrupted version in the default file path.  At first, the backup database showed up in the server (still closed though), but now nothing shows up in the FM Server under the "Database" tab.  What have I done wrong and how do I correct it?

            • 3. Re: Can't restore backup database in FM Server 8.0
              philmodjunk

              Have you followed any of the suggested steps above?

               

              Can that back up copy be opened directly with filemaker or do you get an error message?

              If it can't be opened, can you recover it?

               

              Renaming and moving the file into the correct folder works for me as a way to update files in Filemaker server 10. I don't know if that'll work in server 8. You may have to use an "upload" operation--check your documentation for instructions.

              • 4. Re: Can't restore backup database in FM Server 8.0
                Pam3000

                I'll try your suggestions above and let you know either way.  I'm hoping a reinstall won't be necessary.  I'm not too familiar with FM or Macs (haven't worked on one since the early '90s...I'm a PC gal), so the idea of a reinstall makes me feel a bit nervous!

                • 5. Re: Can't restore backup database in FM Server 8.0
                  Pam3000

                  Well, I can't check the database file on any other system since I can't seem to burn the file to a disk.  I'd like to just send the file directly to my PC using an online ftp service, but my boss won't let me download a browser onto the Mac where the FM Server is located (Mac's Safari can't connect to any ftp services).  Anyway, I did manage to get the file to show up again in the Database tab.  When I renamed the file I somehow added an extra space, and FM didn't like that.  The database still remains closed.  When I select Open Database, the status flickers to "opening" for a split second, but that's it.  Nothing happens.  I'm at a complete loss as to what to do now.

                  • 6. Re: Can't restore backup database in FM Server 8.0
                    philmodjunk

                    Is this strictly a web published database?

                     

                    If not, can't you simply copy the file across the network to your machine?

                     

                    Or install filemaker pro on the server and open it there?

                     

                    Or copy the file to a USB drive....

                    • 7. Re: Can't restore backup database in FM Server 8.0
                      Pam3000

                      Before I begin, I'd like to express my sincere gratitude to Phil for his patience and excellent suggestions. 

                       

                      I was finally able to convince my boss to let me install FM Pro on the server.  The reason he was so reluctant in the first place is that the developer who set up FM Server on our Mac apparently told my boss to NEVER add anything else to the system and to let it stay on 24/7.  Well, the power outage took care of one of those things anyway. 

                       

                      So, here is how it stands.  After attempting to unsuccessfully open and then recover the most recent backup database files in FM Pro, I tried recovering the file that was saved when the power failed.  This worked (hooray!), and we are able to access the file remotely, but the database is unfortunately incomplete.  As I mentioned previously, the full database file is 88 MG in size, while the incomplete file is only 17 MG.  As you can see, we are missing a LOT of data! 

                       

                      The error message that is displayed when I try to open or recover the other backup files is this:

                      "The access privileges in this file have been damaged or possibly tampered with.  Please contact Filemaker Technical Support if the problem cannot be resolved."

                       

                      Believe me, I have not done anything to these files at all.  They are just sitting in the FM backup folder...untampered with...mocking me.

                       

                      We've definitely made some progress (thanks to Phil), but now the question is how can we access or recover the complete backup database file?

                       

                      Thanks!

                      • 8. Re: Can't restore backup database in FM Server 8.0
                        philmodjunk

                        That error message is bad news... When encountered, and recover has failed to fix it, you're usually stuck. Do you have any other backup copies or just the one?

                         

                        We keep rolling daily backup copies of all our files for at least 21 days worth of data--pulling one copy into an archive directory to be kept forever on a monthly basis.

                        • 9. Re: Can't restore backup database in FM Server 8.0
                          Pam3000

                          The backup folder contains several days worth of saved files, all at around 88 MG, but none of them will open or recover either.  Is there really nothing we can do to retrieve the rest of our database? 

                           

                          I assume since the server can access the incomplete database that a reinstall of FM Server will do no good.

                          • 10. Re: Can't restore backup database in FM Server 8.0
                            philmodjunk

                            I wonder if the hard drive on the server was damaged duing the power failure?

                             

                            I'd have a tech check out your system. You may have to get a company that specializes in data recovery recover the data from your hard drive to another drive and then try to see if you can recover anything from it.

                            • 11. Re: Can't restore backup database in FM Server 8.0
                              Pam3000

                              Hiring a data recovery specialist is definitely a possibility at this point.  I called FM customer service one last time, but they weren't very helpful.  I attempted a database recovery one last time on an older backup file from last week, and it seems to be doing something, though I'm not sure if it's actually working to rebuild the database or if it's just stuck in a loop.  Whenever I tried to recover any of the other backup files, the process went as far as Step 2 before the access error message popped up.  This time, for some unknown reason (perhaps I didn't try to recover this particular file the first time around), the recovery progressed to Step 4 (Rebuilding Tables).  This has given us some hope, but the status bar (about 95% complete) has not moved in the past couple of hours.  The database is 88MB, so is it possible the recovery process could actually take several hours to complete?

                              • 12. Re: Can't restore backup database in FM Server 8.0
                                philmodjunk

                                I would think the recover process would work much more quickly than that for an 88 MB file.

                                • 13. Re: Can't restore backup database in FM Server 8.0
                                  Pam3000

                                  I canceled the process, and it looked as if there might have been a partial recovery, but when I tried to open the file, the same old error message came up.  I've tried recovering and importing all the backup files, but none of them can be accessed, which seems really odd.  Why would I receive an error message on all the backup files?  The only file we're able to access is the one that was saved at the time of the power failure, which contains only 20% of our entire database. 

                                   

                                  The only thing I didn't try is an uninstall/reinstall of the FM Server. 

                                   

                                  I think it's time to call in a specialist.