4 Replies Latest reply on Apr 22, 2015 1:43 AM by JonJ

    Cannot deploy WebD

    JonJ

      Title

      Cannot deploy WebD

      Your post

      Hi,

      I'm trying to deploy WebD on a Windows server 2012 with an existing FileMaker Server install. This is a single-server setup, as WebD will only have light usage.

      I used the normal admin console tools to modify the server deployment, but the deployment fails as it can't contact the test_xml file on http://127.0.0.1:80/fmi-test/test.xml

      The reason is obvious — the physical path where I'd expect to find the WebD web share (C:\Program Files\FileMaker\FileMaker Server\HTTPServer\conf) is empty.

      I tried stopping the filemaker service and running a repair install of FM server, which completed without errors or complaints. However, the folder is still empty. 

      How can I force the redeployment of the WebD files? Do I need to adjust anything on IIS first (at the moment there's just the Default Web Site running, but no apps or services are using it, just the default 'welcome to IIS page')

      Am I going to have to do a clean install of FM server? :(

      J.

        • 1. Re: Cannot deploy WebD

          JonJ:

           

          Thank you for the post.

           

          A few questions to assist us with narrowing this down:

           

          1. Did deployment fail to an error and if so, what was the specific error message?

          2. If the IIS role is removed and then the server is redeployed, does deployment succeed?

          3. If no errors were thrown during deployment, then does the WebDirect test page work from the FileMaker Server? (Click the link below.)

           

          https://localhost/fmi/webd#FMServer_Sample

           

          TSFalcon

          FileMaker, Inc.

          • 2. Re: Cannot deploy WebD
            JonJ

             

            Hi,

            Things have moved on a bit, as this is a production server, and clients are getting agitated. 

            I tried uninstalling FMserver, removing any residual folder (uninstalling always leave behind the data folder, for example) and removing the IIS role from the server. 

            I then restarted the server.

            Then I redeployed IIS (default settings), and finally reinstalled FMS (no complaints, except letting me know that it needed to take ports 80 & 443 from the default website.

            The install file runs, but the server deployment wizard again fails when it comes to web services:

            =================

            SETUP: PRECONFIGURE WEB SERVER: passed

            Create IIS backup: passed
            Check to make sure FMI web site exists: passed
            Create app fmi-test: passed
            Test web server (http://127.0.0.1:80/fmi-test/test.xml): Error code = 500

            =================

            Looking in iE, that URL gives me  500.19 - Internal Server Error

            Error Code 0x8007000d 

            The fmi-test folder exists and its contents look OK. IIS shows it added as an application in the FMWebSite.

            It looks like the web.config file is wrongly configured? Or there are incorrect permissions on the fmi-test folder?

            Regards,

            J

             

             

            • 3. Re: Cannot deploy WebD

              JonJ:

               

              Thank you for the reply.

               

              “Then I redeployed IIS (default settings), and finally reinstalled FMS (no complaints, except letting me know that it needed to take ports 80 & 443 from the default website.”

               

              The installation will enable and configure IIS, so do not enable IIS prior to the installation. 

               

              Is the operating system Windows Server 2012 Standard and not R2 or another flavor?

               

              If the IIS role is removed and then the server is redeployed, does deployment succeed?

               

              If not, then perform the following steps for a clean wipe of all necessary components and then reinstall:

               

              1. Uninstall all of the following from Add/Remove:

               

                  a. FileMaker Server 13

                  b. Java (all versions)

                  c. Bonjour

                  d. IIS URL Rewrite Module

                  e. Microsoft Application Request Routing

                  f. Microsoft External Cache for IIS

                  g.  Microsoft Visual C++ 2012 Redistributable Package (x64) 

                  h. Microsoft Web Farm Framework

               

              2. Remove the IIS role from Server Manager

              3. Restart the computer

              4. Delete the inetpub folder located on the C:/ drive

              5. Delete or rename the FileMaker Server folder located on the C:/ drive

               

              Afterwards, reinstall FileMaker Server 13.0v5/9 with the full installer from your store email or the article below.

               

              Installing a previous version of FileMaker software

               

              Please let me know if any of the above requires additional clarification. 

               

              TSFalcon

              FileMaker, Inc.

              • 4. Re: Cannot deploy WebD
                JonJ

                Thanks! That did the trick! 

                J.