3 Replies Latest reply on Sep 29, 2011 7:31 AM by TWE

    Cannot upload database

    MurrayN

      Title

      Cannot upload database

      Your post

      I'm fairly new to filemaker server but no stranger to databases in general. I'm using Windows server 2008R2, Filemaker server 10. I have a new virtual server just been set up for me by a colleauge. It has one database on it. I am trying to upload another database through the admin console. I get the following error...

      "One or more of your destination folders does not have enough space for the specified upload or it does not exist."

      There is plenty of space (over 90gb), and the folders exist. I'm using a domain administrator account, and even opening up the destination folders to allow full access to everyone doesn't make a difference, so I'm pretty certain it's not a permissions problem.

      Now, I have been told by a certified filemaker trainer that you should always use the "upload" or "remove" commands to add and remove databases, and NOT cut and paste. I know for a fact that my colleague used the cut and paste method when he installed the first database. I would like to do things the right way, but can't get past this error.

      My question is two-fold...

      1. What could be causing the error stopping me from uploading?

      2. If it works, is the cut and paste method really so terrible?

       

      Thanks in advance for any suggestions.

        • 1. Re: Cannot upload database
          MikeyG79

          the "manual" copy and paste is fine as long as the databases that you are moving around are closed in the FM Server

          • 2. Re: Cannot upload database
            MurrayN

            Thanks for your reply.

             

            In this case they are coming from another server. So i guess I really should be uploading, rather than copy and paste. Unfortunatly it seems that when the server was set up the initail DB was not uploaded (or created) but pasted. Would the error I'm encountering above be the likely result of that?

            Can anyone suggest how I should proceed? Upload to a different location? Add particular permissions? Re-install?

             

            • 3. Re: Cannot upload database
              TWE

              I encountered this problem recently while trying to load 2 converted FileMaker databases (FP3 -> FP7). I had done this successfully before but now it was failing with the same "One or more ..." error you got. Using the FM Server 10 client running on Windows 2003 I tried to shut down the database. That failed with the content free dialog stating "Error encountered trying to shutdown Database Server."  The FM server logs didn't show this error and so provided no further insight. The old standby for windows is to reboot and try again, which I did. This time the FMS client said the database was down and wouldn't come back up. Each attempt caused the hourglass mouse icon to appear for 2 minutes. No dialog, no server error log message. Now that all FM databases were down, my only other recourse was to 'reboot and try again'. (Isn't that the definition of insanity: trying the same thing and expecting different results?) After the second reboot the FMS client showed that the database server came up and all FM databases were up. I tried loading the 2 converted FM database that failed earlier, and they both loaded successfully.