3 Replies Latest reply on Jun 26, 2009 11:41 AM by TSGal

    Custom web publishing comes up blank

    user21388

      Title

      Custom web publishing comes up blank

      Your post

      Hi all,

       

      this is a bit frustrating. I've loaded a database to my FMS9 Advanced and adjusted the permissions for IWP and php.  I can access the file via IWP but it's not what I want.  So I launched the PHP site assistant and went through step by step.  When I got to the end of wizard I click the preview site and it's blank.  I've saved it to the web directory, still blank.  Thinking it may have been the database, I tried even the included sample db and it does the same thing, all of the other web publishing types work but the php pages come up blank. Any suggestions?

       

      Here is my server info:

      Single machine install
      10.4 server
      Filemaker advanced 9 (with all updates applied)
      Apache 1.3
      FileMaker PHP (though I've tried both)

       

       

      thx,

      scott 


        • 1. Re: Custom web publishing comes up blank
          zombiewoof
             Did you ever get this figured out?  I'm experiencing a similar problem on my 2 machine installation, with the added twist that it used to work, and as far as I know nothing has changed, except now it doesn't work.  I posted my inquiry today, but based on the age of yours and the fact that there has been no response I'm not too optimistic.
          • 2. Re: Custom web publishing comes up blank
            user21388
              

            No, I never did.  The weird part of the whole thing was I was able to the XML site assistant with no problems, just not the PHP.  I upgraded to 10.5 server (fresh install) and FileMaker 10 server and the problem did not reappear.  Sorry know this doesn't help.

            • 3. Re: Custom web publishing comes up blank
              TSGal

              smartin73 and zombiewoof:

               

              Thank you for your posts.

               

              There were a number of posts that went either "unanswered" or "missing", so I apologize for the late reply.

               

              With FileMaker Server 9, there was a problem reported where the preview site (using PHP) was blank.  This appears to have been caused by a blank layout being referenced.  When you select layout groups, the blank layout isn't listed but then displays the blank layout.  The view is not refreshed until other layouts which has some fields are selected.

               

              This was fixed in FileMaker Server 10.

               

              TSGal

              FileMaker, Inc.