2 Replies Latest reply on Oct 24, 2008 5:50 AM by oakhamschool

    Custom Web Publishing Startup Issue

    Strad

      Title

      Custom Web Publishing Startup Issue

      Your post

      Hi,

      Filemaker Server Advanced 9.0.3.325

      Mac OSX Server Unlimited 10.5.2

      PHP 5.2.4

       

      I have manually installed the Filemaker API in the Library/Documents on the OSX server as per instructions in the FM Custom Web Publishing manual. I fired up the FM_Sample DB from the Admin console and clicked on the Custom Web Publishing test page.....

       

      My browser is outputting this error:

       


      Warning: require_once(FileMaker.php) [function.require-once]: failed to open stream: No such file or directory in /Library/FileMaker Server/Web Publishing/web-server-support/test/fmi-test/phptest.php on line 5

      Fatal error: require_once() [function.require]: Failed opening required 'FileMaker.php' (include_path='.:') in /Library/FileMaker Server/Web Publishing/web-server-support/test/fmi-test/phptest.php on line 5

       

       

      Why ?

      Help?

       

      Strad 


        • 1. Re: Custom Web Publishing Startup Issue
          rmanook

          Hi Strad,

          Thanks for posting!

           

          To start, do you have any issue with XSLT test page or the IWP test page?  In the Admin Console > FileMaker Overview page is everything listed green?

           

          While I know that it is a tedious process, the best cure for Web Publishing startup issues is a clean un/re-install for FileMaker Server.  You can try a Server re-deployment as I have seen that work in quite a few cases as well.  At least, it is worth a try prior to having to un/re-install your configuration. 

           

          For un/re-installing:

          1.  Close out databases and drag database folder to desktop

          2.  Stop FileMaker Server Services

          3.  Un-install FileMaker Server (if this is a multiple machine configuration, make sure that Library > FileMaker Server folder is removed from both machines)

          4.  reboot

          5.  In Terminal, reset Apache via: sudo cp /etc/apache2/original/httpd.conf /etc/apache2/httpd.conf

          6.  reboot

          7.  Verify all of the ports in Knowledge Base article 6427 are open (Support > Knowledge Base) 

          8.  Re-install FileMaker Server (choose to install FileMaker's PHP for testing purposes) 

          9.  Test!

           

          I apologize we do not have an immediate resolution for this issue as multiple factors can affect CWP.  Let me know how it works out. 

           

          Thanks!

          tsturtle

          FileMaker, Inc. 

          • 2. Re: Custom Web Publishing Startup Issue
            oakhamschool
              

            Hi Strad,

             

            I've got exactly the same error on Windows? I've tried reinstalling the software and gone through the Server patches in sequence, but it hasn't solved it.

             

            If you find an answer please post back......

             

            I've also got the same issue (or the same error on line 5) on a Windows 2003 Server machine

             

             Warning: require_once(FileMaker.php) [function.require-once]: failed to open stream: No such file or directory in C:\Program Files\FileMaker\FileMaker Server\Web Publishing\web-server-support\test\fmi-test\phptest.php on line 5

            Fatal error: require_once() [function.require]: Failed opening required 'FileMaker.php' (include_path='.;C:\Program Files\FileMaker\FileMaker Server\Web Publishing\publishing-engine\php\PEAR;C:\Program Files\FileMaker\FileMaker Server\Web Publishing\publishing-engine\php\FileMaker') in C:\Program Files\FileMaker\FileMaker Server\Web Publishing\web-server-support\test\fmi-test\phptest.php on line 5