AnsweredAssumed Answered

Error 685, problem deleting backup - single file in directory

Question asked by disabled_JustinClose on May 20, 2013

Title

Error 685, problem deleting backup - single file in directory

Your post

     This question is very similar to this thread on FMForums, but has one major difference:  there is only one file in the subdirectory in question.

     Overall description:  I started getting 685 errors again this weekend: 

Error    685    server.addr.ess    Error occurred while deleting backup folder 
"volume:path/to/file", some files or folders could not be deleted. (-1)

     I thought that I was having the same problem as I had had previously:  something in the path calculation for the external container field had gotten messed up (e.g. field renamed) and that all the files were being dumped into a parent directory or something. 

     But that was NOT the case.  In looking at the directory that it said it couldn't delete there was only one directory/subdirectory tree left in that path, with only 1 file in that subdirectory.  I went to that directory in a more recent backup copy (i.e. one that it hadn't tried to delete yet), and there was only 1 file there, too.

     I did a test where I deleted this file and subdirectory from a backup BEFORE it tried to remove it, and I received no error message when that one's turn came up.  I did this a few other times to verify.  So deleting this one file and one subdirectory prevented the error from cropping up.  I also tried deleting just the file (and not he subdirectory) and in those cases I DID get an error when it tried to delete that backup.  So it appears to be something about the subdirectory itself.

     I looked at the permissions on the file and they appeared to match what all the other files in other similar subdirectories were.

      

     Anyone have any ideas?

      

     Thanks,

     --  J

Outcomes