1 2 3 Previous Next 38 Replies Latest reply on Apr 22, 2015 7:30 AM by mhochuli

    FileMaker 13 Server fails to start upon reboot

    PhilipJones

      Title

      FileMaker 13 Server fails to start upon reboot

      Your post

           Hi all,

           I am running into a problem whereby FMS 13 does not start upon rebooting my server computer. I have auto-start configured to be on. When I reboot, the server does not run, and I must enter the command "sudo launchctl start com.filemaker.fms" into Terminal to manually re-start the server.

           Can anyone please offer me any advice?

           Many thanks,

           Phil

        • 1. Re: FileMaker 13 Server fails to start upon reboot
          PhilipJones

               Has anyone else seen this behaviour?

          • 2. Re: FileMaker 13 Server fails to start upon reboot
            JoeSimenstad

                 I am also having this same issue. I just last week upgrade a larger FileMaker Pro Database for a printing company from FileMaker 6 to FileMaker 13. The new FMS is running on a Mac mini Server edition running 10.9.2.

                 Each time I restart the Server FMS does not automatically restart. I have written an AppleScript to autolaunch and start the FMS but why won't it autostart? FMS works fine once it starts.

                 Anybody else? Any idea why?

                 There is a LaunchAgent for FMS in the mail Library folder.

                 Thanks for any help anyone can offer.

                 Joe

            • 3. Re: FileMaker 13 Server fails to start upon reboot

              @Philip Jones: 

                   What operating system is the FileMaker Server 13? 

                    

                   @All:

                    

                   While I have not personally reproduced this issue in house, I encountered this with another customer, also using Mavericks. I am wondering if this issue might be specific to Mac OS X 10.9.x Mavericks.

                    

                   While I cannot pinpoint which specific action resolved this issue, the troubleshooting steps follow:

                    

                   1. Repaired Disk Permissions

                   2. Removed all third party startup items

                   3. Deleted two files:

                    

                   /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

                    

                   /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

                    

                   4. Shut down.

                   5. Reset SMC

                   6. Safe Boot

                   7. Restarted

                    

                   All of these steps may not be necessary every time, but in at least one case, this fixed the issue with the FileMaker Server not starting upon boot, even after multiple attempts at uninstalling and reinstalling had not.

                    

                   Let me know if any of the above needs further clarification. 

                    

                   TSFalcon

                   FileMaker, Inc.

              • 4. Re: FileMaker 13 Server fails to start upon reboot
                PhilipJones

                     Hi,

                     I am running Mavericks (latest updates).

                     I'm sorry, but I think it is absurd that, on the latest Apple software, a server application is not working properly when it is created by an Apple subsidiary!

                     FileMaker needs to fix this rather than make their customers jump through hoops (without even knowing which of the several steps is the magical step which fixes the problem).

                     I will try the suggestions, since I need my server to function correctly after a re-boot. I'm just disappointed that this is what I have to do.

                     Phil

                • 5. Re: FileMaker 13 Server fails to start upon reboot
                  PhilipJones

                       I should also note that FMS is the only software installed on my machine, after a clean install of Mavericks. Therefore, no other software or weird configuration is to blame. My system is otherwise completely vanilla.

                       Phil

                  • 6. Re: FileMaker 13 Server fails to start upon reboot

                    @Philip Jones: 

                         Thank you for the reply.

                          

                         If you can provide me specific steps to replicate the issue, as we have not been able to replicate in house, then a report can be forwarded to Testing and Development for review. 

                          

                         The suggestions provided above are all operating system level troubleshooting. You are correct, we do not know which specific step was the resolution, and if you discover which step while troubleshooting, we would be very happy if you would share that information with the community.

                          

                         What we do know is that the issue was either with the operating system or installed third party software. Nothing about the FileMaker Server 13 installation was changed to resolve the issue.

                          

                         Troubleshooting is the only method we have to determine a root cause.

                          

                    FileMaker Support Methodology

                          

                         Please keep me updated with any progress.

                          

                         TSFalcon

                         FileMaker, Inc.

                    • 7. Re: FileMaker 13 Server fails to start upon reboot
                      JoeSimenstad

                           @TSFalcon

                           I too am running a fairly vanilla system. It is a Mac mini Server Edition with 10.9.2 running latest Server app. The only Server service running is File Sharing so far. This is a brand new machine and has little to no non-Apple SW installed. The machine was just setup and it has never run anything other than 10.9.2 so I don't know if this issue started in 10.9.2 or was present prior.

                           I worked for 8+ years for Apple Inc. as a Mac Genius and have done extensive troubleshooting in the past. I can help out, but this machine is a critical system used by a client so I have little ability to do anything during business hours. I have looked through the logs and have not seen anything that seems to indicate an issue. As I said earlier the FMS entry does exist inside LaunchAgents in the root Library folder.

                           I will perform a couple of the steps you have suggested. I can only do so much since most of my work on the machine is done remotely. The machine is over a half hour away from my office.

                           Thank you for your assistance!

                           Joe

                      • 8. Re: FileMaker 13 Server fails to start upon reboot

                        @Joe Simenstad: 

                             Thank you for the reply.

                              

                             Known conflicts exist when using FileMaker Server 13 and the Mac OS X 10.9 Server.app. Since FileMaker Server 13 now builds its own Web Server, the Mac Server.app could be taking over the Web Publishing role and using the ports, thus keeping FileMaker Server from starting.

                              

                             If you remove the Mac Server.app, uninstall and reinstall FileMaker Server 13, then does the issue persist?

                              

                             For a full list of tested operating systems for FileMaker Server 13 see the following:

                              

                        http://www.filemaker.com/products/filemaker-server/server-13-specifications.html

                              

                             Mac OS X 10.9 Mavericks without server is tested to be compatible. 

                              

                             TSFalcon

                             FileMaker, Inc.

                        • 9. Re: FileMaker 13 Server fails to start upon reboot
                          DeanIngram

                               Some problems we have here with FMS not getting along with Mavericks Server are that 1) several of my installations are using the DNS server functionality of OS X Server to provide name resolution for the FileMaker Server on the LAN and 2) how are we supposed to configure FMS to authenticate via LDAP?

                               With the server.app gone and internal DNS not functional, users on the LAN will be back using an IP address from inside the office and using the FQDN outside the office. That's not a realistic option, or at least not an option that makes FMS look very good, especially since it used to work before the new server was installed.

                               I suppose we could buy a whole different Mac just to run OS X server for OpenDirectory and DNS but no. That's not realistic either. We really need FMS 13 to work on Mavericks servers.

                          • 10. Re: FileMaker 13 Server fails to start upon reboot

                            @All: 

                                 Thank you for the replies.

                                  

                                 When this occurs, does the Mac OS X system.log (Finder > Go to Folder > /var/log/ ) indicate an error? 

                                  

                                 For example:

                                  

                                 Apr 15 10:42:17 localhost com.apple.launchd[1] (com.filemaker.fms[74]): getpwnam("fmserver") failed

                                  

                                 If getting the above error, then the launchd is failing to detect the fmserver user. 

                                  

                                 This would explain why the server runs fine after the "sudo launchctl start com.filemaker.fms" command. Development and Testing is currently investigating why launchd fails to detect the fmserver user.

                                  

                                 TSFalcon

                                 FileMaker, Inc.

                            • 11. Re: FileMaker 13 Server fails to start upon reboot
                              JoeSimenstad

                                   @TSFalcon

                                    

                                   My system log does not show this as an entry, but it is possible they have rolled over to many times for it to still be in the system logs.

                                   When next I restart that server I will take a look for this error.

                                   Joe

                              • 12. Re: FileMaker 13 Server fails to start upon reboot
                                JoeSimenstad

                                     Interesting. I will give this a try. I have been using the Terminal launchd option and it seems to work but it kinda stinks having to run a startup script just to get it working. I hope this solves my issue as well.

                                     Thanks,

                                     Joe

                                • 13. Re: FileMaker 13 Server fails to start upon reboot
                                  lhoong

                                       Wolfgang, your fix worked perfectly for me when I encountered this issue on a client's FMS13 installation. Fixed/propagated permissions for the FileMaker Server folder to enclosed items and FMS13 auto-started on reboot.

                                       Thanks!

                                       Lee.
                                        

                                  • 14. Re: FileMaker 13 Server fails to start upon reboot
                                    chrei

                                         Exactly the same problem here - on a completely fresh installed Mavericks machine.

                                         I didn't realize the problem with the initial installed FMS 13, but the problem occurred after upgrade to v3 and remains with upgrade to v4.

                                         When the problem exists, I can find error messages like these in the Console:

                                    13/08/14 14:02:07,115 com.apple.launchd[1]: (com.filemaker.fms[126]) getgrnam("fmsadmin") failed
                                    13/08/14 14:02:07,115 com.apple.launchd[1]: (com.filemaker.fms[126]) Exited with code: 3

                                         or - another time - 
                                    13/08/14 17:25:57,154 com.apple.launchd[1]: (com.filemaker.fms[116]) getpwnam("fmserver") failed
                                    13/08/14 17:25:57,155 com.apple.launchd[1]: (com.filemaker.fms[116]) Exited with code: 3

                                         @FileMaker: Is there any news what could be the reason of the problem?

                                         Thanks

                                          

                                         Christoph

                                    1 2 3 Previous Next