1 2 Previous Next 17 Replies Latest reply on Dec 8, 2011 12:00 PM by NicolayFlaaten

    Filemaker server 11 adv Crashing

    truji_

      Title

      Filemaker server 11 adv Crashing

      Your post

      I've searched all over the place but I have not been succesful at identifying/fixing my issue.

      I have  FMP 11 Adv server running on a Intel Xeon 2.13Ghz with 12GB ram on Win Server 2008 R2 64 bit

       

      I have 3 hosted FMP files. All users connect from IWP. From time to time, the server hangs/crashes - about two times per day, mostly on 'peak' hours. The server has not crashed on weekends.

      While the problem seems to be for only 1 of the databases, IWP will not respond. The browser spins and spins. However,  having FMP 11 Adv open, I can switch to the other 2 databases but I cannot switch to the one with the problem.

      I have tested all my scripts both in IWP and FMP but none of them go into an infinite loop or make the system crash.

      When I open the Admin console, the Elapsed time call is in the millions. I tried disconnecting some users and while it seems that by disconnecting some of the users the browser stops spinning and 'opens' up the 'select a database', the databases won't load after entering user/password.The only solutions are to restart the pc or to stop web publishing/server.

      I use some external scripts (remote scripter from 360 works)

      I did  a 'recover' on the file. Data is fine but I got Structure: scanned; 4 item(s) modified. How critical is this error?

      I looked at the error logs but they don't offer much of a help except errors 802 (unable to open file) when the system goes down.

      Please advice.

       

      Thank you,

       

        • 1. Re: Filemaker server 11 adv Crashing
          philmodjunk

          The problems found during the recover could very easily be the reason your server is hanging on that file.

          Did the Recover process say the recovered file was "ok to use"?

          Things to keep in mind about Recover:

          1. Recover does not detect all problems
          2. Recover doesn't always fix all problems correctly
          3. Best Practice is to never put a recovered copy back into regular use or development. Instead, replace the damaged file with an undamaged back up copy if this is at all possible. You may have to save a clone of the back up copy and import all data from your recovered copy to get a working copy with the most up to date information possible.
          • 2. Re: Filemaker server 11 adv Crashing
            truji_

            Thanks Phil for your answer.

            No, the recover did not say 'ok to use'.

            I performed the recovery on a backup but not the the actual hosted file.

            Unfortunately, the backups/clones that I have, have the same issue. How do I fix the structure ? Do I need to run recovery on the hosted file ? if so, what would be the next step?

            Thanks again.

            • 3. Re: Filemaker server 11 adv Crashing
              philmodjunk

              I would expect that you would get the same result if you pulled the hosted copy off the server and recovered it.

              This issue may or may not be the cause. If you delete the recover log and run the recover again, (Recover will append results to an exisitng log so deleting the log first makes sure that all entries apply to just the most recent recover operation.) you can carefully read down through the log to identify the 4 entries where something was changed. Hopefully, you can at least identify the layout or other database element that was changed.

              There is one known bug in Recover that can produce this result when there is, in fact, no damage to your file so you have to check and see if this applies:

              For More Information see:     FMPA 10: group graphic + align = corrupt file?

              This is one of many acknowledged bugs that can be found in the Known Bug List here in the Report an Issue section of the forum.

              It can also be downloaded as a database file from:    http://www.4shared.com/file/8orL8apk/FMP_Bugs.html

              If you think this might be a possibility, try taking a copy of your file, going to each layout and:

              1) enter layout mode
              2) Select all objects on the layout
              3) Ungroup them. (I know, this disables most buttons as they are also grouped objects.)
              4) Close this copy and recover it.

              If it's the "alignment bug" that's causing the recover process to report a problem, this copy should recover without any problems found.

              If all else fails, you may have to delete portions of your database file until what's left recovers without any error reports. Then you'd rebuild the deleted sections one section at a time, using recover to see if it finds any problems. Tedious but can be much less work that starting over from a blank page.

              You might also web search for FMDiff--a third party utility--to see if it might offer a more complete picture of what is possibly wrong with your file.

              • 4. Re: Filemaker server 11 adv Crashing
                truji_

                Dear Phil,

                I run a recovery on the recovered file and no errors were detected.

                I opened the log file, went to each layout that appeared to have an error, selected all and ungrouped everything. Ran the recovery again and no errors were found.

                Will this bug cause the system to crash? I'm going to try and ungroup everything on the hosted file and see if the system crashes again.

                Please let me know if there is anything else I need to do.

                Thank you!

                • 5. Re: Filemaker server 11 adv Crashing
                  philmodjunk

                  It's a bug in the recover process that causes it to report a problem when none actually exists. To my knowledge it won't cause a crash.

                  I opened the log file, went to each layout that appeared to have an error, selected all and ungrouped everything. Ran the recovery again and no errors were found.

                  Did you recover a copy of the original file or the copy produced by your first recover? This should be done with a copy of the original, unrecovered file.

                  • 6. Re: Filemaker server 11 adv Crashing
                    truji_

                    I made the fix in the original file, then I did a backup and ran the recovery on the backup. 0 Errors were found. However, I found this in the log:

                    Adjusted item count of library  (0) by -2

                    Found 1 stranded library object(s)

                    Recovered 1 stranded library object(s) for a total of 3851 byte(s)

                    Can this crash the file? if so, how do I fix it?

                    • 7. Re: Filemaker server 11 adv Crashing
                      philmodjunk

                      I have no idea. One of the issues with Recover is that there's no way to know exactly what got changed and how even if you can fully decipher what is reported in the recovery log.

                      You might want to check out FMDiff and see if it provides any useful info on your file. (This is a third party utility you can purchase.)

                      Safest bet is to find a back up copy that recovers cleanly and to import the data from your recovered file into it. Since this isn't an option, you may need to rebuild the file a piece at a time. It's possible to import or copy and paste portions of your current file into a new file, but the file corruption may be brought into the file with the elements that you imported/pasted. I've been able to get away with this in the past by doing frequent recovers during the rebuild, (Use the recover to check, but then discarded the recovered copy), reverting to a previous copy if the recover reported a problem. Tedious as all get out for a complex database, but it did fix the problem for me once I got it all put back together.

                      • 8. Re: Filemaker server 11 adv Crashing
                        truji_

                        Thanks Phil.

                        Here is what I did before doing what you told me. I went backwards.

                         

                        I took the clone database with the stranded library of 3k~. Started deleting layouts, scripts, tables etc one by one and doing recoveries in between. Turns out that I deleted everything from the database, except this time the size of the stranded library is close to 6k. How does this make sense?

                        ...and what is the point of doing a recovery if you cannot use the 'fixed' file? to tell you that your database has problems but without an idea on how to fix them?

                        • 9. Re: Filemaker server 11 adv Crashing
                          truji_

                          FYI- I opened the recovered file (after deleting everything) and it 'recovered' one table called 'recovered library' with 2 fields.

                          "recovered Blob"-container and "From Table"-text

                          We used an old database where users imported files into containers but they were stored as blobs. Could it be that in the transfer they got messed up? But, since I deleted all the tables, why is this error still there?

                          • 10. Re: Filemaker server 11 adv Crashing
                            philmodjunk

                            The primary purpose of Recover is to get your file into a state where you have the best possible chance of rescuing your data by importing it into an undamaged clone of the same file. Repairing the file so that it works correctly is a secondary concern. Think of using the Jaws of life to rescue people from a crushed car, but with repair tools attached to it. The main job is to rescue the people (your data) if it can then repair the file, all to the good, but it's safer to move your people into a brand new car instead.

                            Recover does fix files and often you can go ahead and use that recovered file. It's just that you have no guarantees. That's why importing to a backup is a "best practice" recomendation.

                            I'm not a FileMaker Programmer and have never seen how they put the database together on the inside so I can only speculate that what you are finding here are broken references to your container fields (Such as a "blob"). It may not be possible to remove these broken structures from your damaged file. Instead, you may need to start with a brand new file and import the structures, scripts, layouts (copy and paste) you want to keep into this new file. This is very tedious and time consuming, but I don't have any better recommendations for you here. There a 3rd party tool, FMMigrator that I've heard about that is supposed to take a lot of the drudgery out of moving elements from one file to another.

                            • 11. Re: Filemaker server 11 adv Crashing
                              NicolayFlaaten

                              I have experienced crash with fmps11, and could not find the cause. But when we turned on ssl in the fmps server the problem disapeared. I think some errorchecking fixed some network traffic that went wrong. Maybe this is not the solution for you, but you can give it a try. 

                              It is under Configuration/Databa Seserver / Security.

                              • 12. Re: Filemaker server 11 adv Crashing
                                truji_

                                Thanks Nicolay.I will try this.

                                Do I just turn SSL on? is there anything else I need to do? Like I said, all the users use IWP, will the url need to change to https?

                                • 13. Re: Filemaker server 11 adv Crashing
                                  NicolayFlaaten

                                  You just have to stop the server, and start it again after you have turned on ssl. The users dont have to change anything.

                                  If you get any problems, you can just turn it of, and stop and start the server again to excecute the change.

                                   

                                  Nicolay

                                  • 14. Re: Filemaker server 11 adv Crashing
                                    truji_

                                    Ok. I have absolutely no idea how to proceed now.

                                    I copied all the data, layouts, value lists, scripts etc etc to a newly created database while running recoveries after every step.

                                    Absoultely no errors, stranded libraries, etc etc were found.

                                    15 minutes after I open the database  (iwp users only) the server crashes. What can I possibly do???

                                    1 2 Previous Next