1 Reply Latest reply on Dec 8, 2014 6:47 AM by MaltaCode

    Filemaker Server 12 Adv. -> FM PHP on CentOS Server

    MaltaCode

      Title

      Filemaker Server 12 Adv. -> FM PHP on CentOS Server

      Your post

      I have Filemaker 12 Adv. Server running at a clients office and he has a CentOS linux web server running in a datacenter. I've copied the FM_API_for_PHP_Standalone.zip file to the CentOS webserver and unpacked the files in /home/admin/FileMaker (so that folder has the FileMaker.php and FileMaker folder in there). I've set the include_path correctly in php.ini. The connection to the OSX FMS12A server was setup correctly and tested, it works.

      The FM-Php application I am running used to run on the same OSX server (locally) in PHP and runs correctly. As soon as I move it to the CentOS server the connection to the database is made (no errors) but after that I run in a lot of errors, mainly because commands are not found. Two of the main errors I get are:

             
      1. Fatal error: Class 'FileMaker_Command_Find' not found in /home/admin/FileMaker/FileMaker/Implementation/FileMakerImpl.php
      2.      
      3. Error: 3 - Command is unavailable (for example, wrong operating system, wrong mode, etc.)

       

      The first error seems to be created by not being able to load the files, although they are in the path I've partly solved that by using;

             
      • define('__ROOT__', dirname(dirname(__FILE__)));
      •      
      • require_once (__ROOT__). '/Command/Add.php';

       

      But it does not solve all problems on finding the correct FM commands.

      The second problem is caused by the ExitOnError($layout); command.... I guess this is caused by the same error. 

      I believe that is is a very simple thing that is causing all these errors, something like the magic_quotes or perhaps the difference between PHP Version 5.3.29 on the CentOS server and PHP Version 5.3.13 on the OSX server... but I am not a php expert so desperately seek some help on this....

      Hope someone can help me out here....

      MaltaCode