3 Replies Latest reply on May 7, 2014 10:42 AM by MikeMcintyre

    FileMaker Server 13.0v2 update - seems to abort during installation

    MikeMcintyre

      Title

      FileMaker Server 13.0v2 update - seems to abort during installation

      Your post

           After the initial window about extracting files, I saw the following message in a popup window:

           Uninstalling Application Request Routing 2.5...

           After a minute or so, that window was replaced by one that said the following:

           Installing Application Request Routing 3.0...

           After three minutes or so (didn't time it exactly), that window disappeared and then nothing else happened - no error message, no confirmation of update installation completion, nothing.

           I restarted the FileMaker Server service, and I can still connect to our database on the server, but I can no longer connect to the server via the admin console (my Chrome browser reports, "The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.").

           My guess is that the update installation is aborting prematurely, and that most of the update has not been applied.

           When I try to reinstall the update, I get the same result except that the uninstall of ARR 2.5 does not occur.

           Any thoughts on what's wrong and/or what I need to do in order to install the update correctly (and get admin console back)?

           Oh, and I was updating from 13.0v1a.

        • 1. Re: FileMaker Server 13.0v2 update - seems to abort during installation
          philmodjunk

               It would appear that you have been bitten by a "bug" in the installer code--the error message is misleading according to the following report.

               See if this thread helps:     FMS 13 won't install on Windows Server 2008 R2. Complains that ARR cannot be found.

               This is one of many acknowledged bugs that can be found in the Known Bug List thread here in the Report an Issue section of the forum.

               It can also be downloaded as a database file from:    https://www.dropbox.com/s/jt09b82i0xijbu3/FMP%20Bugs.zip

          • 2. Re: FileMaker Server 13.0v2 update - seems to abort during installation
            MikeMcintyre

                 I'd forgotten that FM13 Server (or its installer - not sure which) didn't like ARR 3.0 (maybe only in conjunction with Win Server 2008 R2, which is what I have - again, not sure), and so a manual pre-install of ARR 2.5 was necessary prior to installing FM13 Server.  So much for the past.  But now this update installer for 13.0v2 wants to uninstall ARR 2.5 and install ARR 3.0.  So does that mean, by implication, that Win Server 2008 R2 is no longer supported by FM13 Server, or does it mean that FM13 Server now works properly with ARR 3.0 in all OS environments?  Except that the latter would seem not to be true, since the installer is aborting in my OS environment.

            • 3. Re: FileMaker Server 13.0v2 update - seems to abort during installation
              MikeMcintyre

                   Ok, so I called support, and for my situation I was advised to not use the update installer, but to use the full installer (13.0.2.295) instead.  I was told to uninstall FM Server and then to reinstall it.  I was also told that if the reinstall didn't work, it would probably be because of certain IIS-related components, which I should manually uninstall, and then try the FM Server install again (this part didn't turn out to be necessary for me, by the way).  When I did the reinstall, it got to the point where it said "Installing Application Request Routing 3.0..." and after several minutes passed, it came up and said something to the effect that it couldn't access ARR 3.0 via the internet, and that I would either have to enable internet access and try the install again, or manually install ARR 3.0 and try the install again.  My server is firewalled off from the internet and it wouldn't be easy to open up access to the internet.  So I found the web page (http://blogs.technet.com/b/erezs_iis_blog/archive/2013/11/27/installing-arr-manually-without-webpi.aspx) that explains how to manually install ARR 3,0, I reran the install again, and all was finally well.  Of course, the uninstall / reinstall sequence meant that I had to upload my previously backed-up copies of my databases to FM Server, after the reinstall, and I had to reconfigure my schedule for the backup, but outside of that, for me at least, there was nothing else I needed to do.

                   My strong suspicion is that the update installer that I first tried to use was simply dying off without issuing a meaninful error message, i.e. to the effect that it could not access ARR 3.0 via the internet, and that I probably could have manually pre-installed ARR 3.0 at that point, and then used the update installer (again) to install FM Server, without having to go through a uninstall / reinstall sequence.  But oh well...