11 Replies Latest reply on Nov 25, 2014 12:51 PM by RichardMurff

    FileMaker Server 13.0v5

    RichardMurff

      Title

      FileMaker Server 13.0v5 & WebDirect

      Your post

      I have deployed FM Server 13 across two machines. I have databases being hosted by FM Server that have what I believe are the appropriate settings for being shared via FileMaker WebDirect. I can pull up the FM WebDirect Home Page, but there are no available databases listed.  The server is running Windows Server 2012 R2 Standard edition (64-bit). The web server is running Windows 7 Professional SP1 (64-bit). Everything in the status area of the Admin Console says it's all working and enabled. I've verified all required ports (80,443,5003,16000) are open in the firewall of both machines for inbound and outbound traffic. Can someone tell me what I'm missing? Attached is a screenshot of the WebDirect Home Page.

      WebDirect.jpg

        • 1. Re: FileMaker Server 13.0v5 & WebDirect
          User25291

          Most likely security settings. You need to login with an account that has the "Access via FileMaker Webdirect" extended privilege on. Databases won't show up in the list if there is no account with the privilege on.

          • 2. Re: FileMaker Server 13.0v5 & WebDirect
            RichardMurff

            Thanks Kevin. And you're probably right. Now that I've taken a break from it over the weekend, it just dawned on me that when I access the web page through my browser, it doesn't ask me for login credentials. So, my next question is, where do I log in with an account that has that privilege enabled? I don't see a login button anywhere on the Webdirect page. Also, here's a screenshot of the Webdirect sharing options within the database I'm trying to access.

            • 3. Re: FileMaker Server 13.0v5 & WebDirect
              RichardMurff

              After further review, I don't think I was correct about the login. From what I'm reading in the documentation, as long as I have the "Don't display on FileMaker WebDirect homepage" checkbox cleared, the database should show up in the list on the WebDirect Homepage. The login request should come only after I select the database from the list.

              I have also run the /fmi-test/phptest.php script and received this error, "PHP Fatal error:  Maximum execution time of 30 seconds exceeded in C:\Program Files\FileMaker\FileMaker Server\Web Publishing\publishing-engine\php\FileMaker\Implementation\FileMakerImpl.php on line 373".

              And lastly, I have loaded the /fmi-test/test.xml with this result, "This XML file does not appear to have any style information associated with it. The document tree is shown below." followed by a single tag: "<guid/>"

              It appears that the web server is having trouble connecting to the database server, which is why I was concerned about ports being open. But since I've opened all the ports, I'm stuck. Any suggestions would be greatly appreciated.

              **EDIT: Also, another symptom I'm experiencing is not being able to connect to the admin console of the database server through a web browser on another machine.  Using the IP address of the database server with all possible combinations of ports 16000 and 16001, and http vs. https protocols, all yield the same result: "Web page cannot be loaded".  I can access it fine through a web browser on the database server itself, using the IP address or localhost.

              • 4. Re: FileMaker Server 13.0v5 & WebDirect
                vince@supportgroup.com

                Richard

                I am having the same issue, with a 2 machine deployment, but Mac not Windows.

                1. Can't hit the admin console from another machine

                2. No green icon next to web server on admin page

                3. No embedded images showing up on WebDirect pages

                4. Uninstalled and updated several times and always breaks at v5

                5. Can not redeploy after v5 update

                • 5. Re: FileMaker Server 13.0v5 & WebDirect
                  RichardMurff

                  Vince, I'm not sure if this will help, but when I had the issue with the green icon not appearing next to web server on the admin page, it was because I didn't install the update on the web server first.  Now I have the green checkmark icon next to all the services on the admin page and v5 update working, but still having the issues I described above.

                  • 6. Re: FileMaker Server 13.0v5 & WebDirect
                    vince@supportgroup.com

                    Richard

                    I saw in the Read Me to update the Worker first, but still no love with the green icon. I uninstalled and update 3 times. Have you tried to redeploy the server via the sever menu?

                    Thanks

                    • 7. Re: FileMaker Server 13.0v5 & WebDirect
                      RichardMurff

                      Vince, yes, I did try redeploying from the server, actually several times.  Just tried it again to be sure, and everything succeeded except it complained about a duplicate routing rule.  Here's the log file from this last one:

                      ___________________________________________________________________________________________________

                      Deployment started at 11/24/14 3:43 PM
                      ---------------------------------
                      SETUP: PRECONFIGURE WEB SERVER

                      Check to make sure FMI web site exists                      succeeded
                      Create app fmi-test                                         succeeded
                      Update WPE deployment configuration                         succeeded

                      UNDO EXISTING DEPLOYMENT

                      Step 1: Unconfigure Web Publishing Engine (WPE):
                      Stop WPE                                                    succeeded
                      Set WPE AutoStart to disabled                               succeeded
                      Update JWPC prefs file                                      succeeded
                      Update WPE deployment configuration                         succeeded
                      Step 2: Unconfigure web server:
                      Update WPE deployment configuration                         succeeded

                      START DEPLOYMENT

                      Step 3: Save settings:
                      Save administrative configuration settings                  succeeded
                      Step 4: Configure Web Publishing Engine (WPE):
                      Stop WPE                                                    succeeded
                      Configuring JWPC memory                                     succeeded
                      Set WPE AutoStart to enabled                                succeeded
                      Add JVM Route to JWPC Server XML file                       succeeded
                      Create CWPC prefs file                                      succeeded
                      Update JWPC prefs file                                      succeeded
                      Start WPE                                                   succeeded
                      Update WPE deployment configuration                         succeeded
                      Update mDNS service info                                    succeeded
                      Step 5: Configure web server:
                      Create IIS backup                                           succeeded
                      Check to make sure FMI web site exists                      succeeded
                      Create app fmi-test                                         succeeded
                      Create worker properties file                               succeeded
                      Enable proxy for Application Request Routing                succeeded
                      Create Application Request Routing rules for Help           succeeded
                      Create Application Request Routing rule for Web Publishing   message:New rule object missing required attributes. Cannot add duplicate collection entry of type 'rule' with unique key attribute 'name' set to 'BlockConf', , .
                      Create Application Request Routing rule for Web Publishing  succeeded
                      Create Application Request Routing action for Web Publishing succeeded
                      Create Application Request Routing match for Web Publishing succeeded
                      Create Application Request Routing rules for Help           succeeded
                      Create Application Request Routing rules for Streaming      succeeded
                      Update FileMaker API PHP setting: : $__FM_CONFIG['hostspec'] = 'http://127.0.0.1'; succeeded
                      Update WPE deployment configuration                         succeeded
                      Add PHP extension to IIS                                    succeeded
                      Set PHP PHP_FCGI_MAX_REQUESTS to 10000                      succeeded
                      Create PHPRC environment variable                           succeeded
                      Add fastCGI handler                                         succeeded
                      Add PHP IsapiCgiRestriction                                 succeeded
                      Set PHP instance max requests to 10000                      succeeded
                      Update FileMaker PHP ini file                               succeeded
                      Create app fmi-test                                         succeeded
                      Update FileMaker API PHP setting: : $__FM_CONFIG['locale'] = 'en'; succeeded
                      Step 6: Configure Database server (DBS):
                      Set WPE Authorization Info                                  succeeded
                      Step 7: Configure AdminServer:
                      Save WPE deployment settings                                succeeded
                      Save web server deployment settings                         succeeded
                      Save DBS deployment settings                                succeeded
                      Start WPE                                                   succeeded
                      Reindex log files                                           succeeded

                      Deployment completed at 11/24/14 3:44 PM

                      ___________________________________________________________________________________________________

                      Maybe you see something I don't. Feel free to send me your log file as well. I am pretty familiar with Macs since I have both an iMac and MacBook Pro that I use at home.  Maybe we can help each other out.

                      • 8. Re: FileMaker Server 13.0v5 & WebDirect
                        vince@supportgroup.com

                        Richard

                        Because this is a production server and I needed to get it back up and running, I demoted it to a single machine deployment and everything is now functioning. We have a development setup that is a multi machine deployment, I will test this further there and keep the forum posted.

                         

                        • 9. Re: FileMaker Server 13.0v5 & WebDirect
                          RichardMurff

                          Vince, by coincidence I did the same thing this morning, converted to single machine. Unfortunately I'm still having issues.  The Web Server is not working and it's got some strange IP address listed.  No matter what I tell it during deployment (the local machine's IP, our web domain that points to our router, our WAN IP) it always puts the same IP address for the Web Server. Still fighting the good fight, but I'm just getting exhausted, lol

                          • 10. Re: FileMaker Server 13.0v5 & WebDirect
                            vince@supportgroup.com

                            Richard

                            The only way I got it to work was to do and Uninstall and then Reinstall v1, Patch v3 and Patch v5. I tried this several times as a two machine setup, but never got it to work past v5, so did it one last time as a single and now it is working.

                            • 11. Re: FileMaker Server 13.0v5 & WebDirect
                              RichardMurff

                              Thanks.  I'll have to try that when no one's here using the databases.  Maybe Friday.  Because we are already running Apache on the server to host AutoCAD interactive web mapping, I am having to use port 85 instead of 80 for IIS/FileMaker Server.  I'm sure this is where my issue is coming from now, but still trying to find out why it's an issue.

                              I do appreciate you keeping me updated on your progress though.  Let me know if you get the two machine deployment working...