3 Replies Latest reply on Feb 28, 2013 3:20 AM by generalche

    Filemaker Server Adv 11 and IWP error

    FrankDias

      Title

      Filemaker Server Adv 11 and IWP error

      Your post

      I have a windows 2011 SBS essential server that i have installed FMSA 11 for some testing. I believe that the installation did not install correctly the IIS environment.

      fms-iwp-error.png

        • 1. Re: Filemaker Server Adv 11 and IWP error
          FrankDias

          I am looking for solutions to the IWP error I am getting. Has anyone else played with SBS2011?

          • 2. Re: Filemaker Server Adv 11 and IWP error
            generalche

                 We are having this exact same problem with FMSA 12 and SBS 2011 essentials too.

                  

                 In our case, checking the FMSA deployment log, there is an error when installing the ISAPI redirect:

                  

                  

                 Add FM Web Publishing ISAPI Filter                           hresult:80070005, message:Failed to commit configuration changes.  , , Access is denied., ,  
                  
                 Adding this filter manually as per http://www.lassosoft.com/Lasso-8-IIS-7-and-FileMaker-Server-11 recomends (or elsewhere on this forum) does not help.
                  
                 There seems to be some incompatibility with the file:
                  
            C:\Program Files\Filemaker\FileMakerServer\WebPublishing\publishing-engine\web-server-support\iis\isapi_redirect.dll
                  
            and SBS 2011. Does anyone have a solution?
            • 3. Re: Filemaker Server Adv 11 and IWP error
              generalche

                   Please disregard my previous message. I have managed to fix the problem.

                    

                   Follow the below steps with respect to enabling 32 bit applications in the default application pool in IIS manager: (it was written for another operating system, but IIS manager is the same, you just get to it from the server console -> roles)

              Enabling application pooling compatibility

                    

              To enable application pooling compatibility with 32-bit applications:
              1. Choose Control Panel > Programs and Features.
              2. Double-click Turn Windows features on or off to start Server Manager.
              3. Expand Roles in the left pane, then expand Web Server (IIS) and select
              Internet Information Services (IIS) Manager.
              4. In the Internet Information Services Manager pane, expand your web server
              name and select Application Pools.
              5. In the Application Pools pane, select DefaultAppPool and click Set
              Application Pool Defaults in the Actions pane.
              6. In the Application Pool Defaults dialog box, select Enable 32-bit
              Application and change the value to true, then click OK.
              7. Right-click DefaultAppPool in the Application Pools pane, choose Stop and
              then choose Start from the context menu.
              8. Verify that there were no errors in starting the application pool.
              9. Close the Server Manager windows and then exit Server Manager.

                   from here: http://permalink.gmane.org/gmane.comp.db.filemaker.devel/33608

                    

                   Aw yiss.