AnsweredAssumed Answered

FM Server 12.0.3.327 Server Side Script Error 100 on Import .csv

Question asked by DocHollywood on Jun 23, 2013
Latest reply on Jun 25, 2013 by DocHollywood

Title

FM Server 12.0.3.327 Server Side Script Error 100 on Import .csv

Your post

     Hello everybody, 

      

     Yet again, I find myself entangled in yet another Filemaker clusterweb: This time, a very easy and straightforward server-side scheduled script that does nothing but import a set of data from a very benign and small import.csv file. 

      

     The long and short of it: I can't get it to run server side - I keep getting error 100 on scheduled execution. 

      

     The script runs perfectly fine when run from a filemaker client instance on that server, so I know the path should be right. 

      

     Where it gets confusing is which paths are accessible from a filemaker server scheduled script instance. All documentation indicates that the Folder should be, on a Mac, /Library/Filemaker Server/Data/Documents - I put it there - to no avail. 

     Then, I decided to trick filemaker into giving me the Documents path that it would expect - and, to my surprise, Get (DocumentsPath) yielded the Documents directory on my Mac (/Users/myuser/Documents) rather than the Filemaker Server Documents directory - and, as you would have guessed it - error 100 still. 

      

     My approach may be moronic, but to all my misery, there was a THIRD Documents folder located at /Library/Filemaker Server/Documents - also tried it with my import step, same result - error 100. 

      

     Am I missing something here? I'm on a Mac Server OSX 10.8. My FM Server version is 12.0.3.327. 

      

     Obviously, I had prefixed all those paths that I attempted with filemac:

      

     I am now thinking about giving a relative path a try - but what on earth is wrong here to not find or be granted access to a file that clearly is where I indicate if would be? 

      

     Thanks for any help!

      

     R

      

Outcomes