0 Replies Latest reply on Aug 5, 2015 7:55 PM by maser

    FMS 14 -- Certificate imported, but client does not show green icon - why?

    maser

      Title

      FMS 14 -- Certificate imported, but client does not show green icon - why?

      Your post

       

      Scenario:   Server's hostname is "a.company.com".  FileMaker Server 14 (on 10.10.4) is set up to point at "a.company.com".   Server already has an Incommon certificate for other services.

      Server has a CNAME:  b.company.com

      FMS 14.0.2 was setup and configured using the stock FM test certificate.   FMS 14.0.1 clients (also on 10.10.4) show the black lock icon.

      I got a Comodo Elite certificate for FMS 14 registered with the name of "b.company.com".   I imported the certificate using the web interface with no errors  (and I have the "custom" and "key" files as expected) and restarted the server:
      fs:cstore root# ls -la

      total 968

      drwxrwxr-x   9 fmserver  fmsadmin     306 Aug  5 21:40 .

      drwxrwxr-x  23 fmserver  fmsadmin     782 Aug  5 17:20 ..

      -rwxrwxr-x   1 fmserver  fmsadmin   54090 Aug  5 21:40 certifiedroot.pem

      -rwxrwxr-x   1 fmserver  fmsadmin   38759 Apr 24 11:14 fmcacerts

      -rwxrwxr-x   1 fmserver  fmsadmin  377375 Aug  5 21:40 root.pem

      -rwxrwxr-x   1 fmserver  fmsadmin    2957 Apr 24 11:11 server.pem

      -rw-r--r--   1 fmserver  fmsadmin    3957 Aug  5 21:33 serverCustom.pem

      -rw-r--r--   1 fmserver  fmsadmin    1834 Aug  5 21:33 serverKey.pem

      -rw-------   1 fmserver  fmsadmin     206 Jul 10 09:10 uninstall.sh

      However, when I reconnect to the server and open the "Sample" database -- the client is still showing me a black lock icon (which is good as it means SSL is still working).

      But why is the icon not green indicating I have a custom SSL certificate?   Is it due to using the CNAME?

      If so, is there a way around this so that clients will see the "green" icon?