AnsweredAssumed Answered

FMS, Apache, PHP and Snow Leopard (10.6)

Question asked by pkaitlyn on Sep 14, 2009
Latest reply on Oct 4, 2009 by Cerniuk

Title

FMS, Apache, PHP and Snow Leopard (10.6)

Your post

Well, the move to Snow Leopard for Filemaker Server 10 is fraught with problems.

 

One I haven't solved yet... two I have...

 

 

The first problem... 

 

Filemaker Server Admin won't load...

 

This was solved by the new all-in-one FMS 10.0.2 updater that was released. Thanks, but finding this new marvel on your website was a painful process at best. So I got the Server to install and load.

 

 

The Second Problem... 

 

It seems that Filemaker Server adds commands to the base configuration file of Apache that don't work with the new version of Apache in Snow Leopard.

 

The additional configurations at the end of the httpd.conf file stop the new version of Apache from working at all since they stop the configuration process... which means that web sharing on a Mac with Snow Leopard is dead in it's tracks for everything, not just Filemaker.

 

Deleting the Filemaker configuration lines at the end of the Apache configuration file solves the problems and will allow Apache to start. Yeah!

 

Here is the path for those with this problem:

 

/etc/apache2/httpd.conf   

 

However, it took me a couple of weeks of Apache down time and several sessions of research to find the solution. Then it took a trip into areas of the Mac OS that aren't normally user areas, to fix the problem, including changing permissions on files I'm not supposed to be able to access.

 

Thanks Filemaker, for being so timely with Updates that allow users to keep up with Apple...

  

 

The Third Problem...

 

Now that I can start Apache...

 

I uninstalled Filemaker Server and re-installed it with the all in one Update to FMS 10.0.2 and presto chango... it works.

 

Not so for the php pages with filemaker code.

 

The Filemaker php pages on the now fixed Apache web server load, but as sorce text only... None of the design, CSS, or fuctionality that was there remains.

 

I assume it's because the PHP code in the configuration file no longer starts the PHP engine of Filemaker Server...

 

Sigh...

 

I have no solution for this one... Except to uninstall and reinstall Filemaker Server... Which I've done to no effect.

 

Anyone have a solution?

 

 

 

 

 

 

Outcomes