1 2 3 Previous Next 63 Replies Latest reply on Jun 8, 2010 2:45 PM by Dave Graham

    FMS10Adv, Admin Console is not showing proper Clients status; server not responding

    CampA

      Title

      FMS10Adv, Admin Console is not showing proper Clients status; server not responding

      Your post

      I am running the latest Mac OS X Server 10.5.6.  (2GHx G5, 7 GB RAM).  After upgrading to FileMaker Server 10, I have been having problems with the Admin Console.  It doesn't respond correctly.  The Connected Clients status only showing one connection, but in fact, there are more than one users connecting to the server. As a result of that, clients would get disconnected from the server unexpectedly.  Here is one of the warning messages: "Client XXXX no longer responding; connection close. (51)". 

       

      I tried to restart the filemaker server, but it won't let me close it.   It seems like the server was not responding.  Then, nothing else I could do but to restart the computer in order to get it back to work again.  Any ideas I can fix this problems. 

       

      Thanks!

       

      Jason

        • 1. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
          rmanook

          Hi Jason,

          Thanks for posting.

           

          Just to verify, does the issue still happen after a Mac OS X Server reboot or have you only experienced this once?  Either way, it may be beneficial to un-install FMS, run repair disk permissions until there are no errors, reboot, and re-install FMS again.

           

          Hope this helps.

          Thanks!

          tsturtle

          FileMaker, Inc. 

          • 2. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
            CampA
              

            HI tsturtle,

             

            Thanks for your reply. After a Mac OS X reboot, the FMS will run just fine for a few days to a week. Then, it will start having the same problems again (i.e. not responding).  I upgraded the OS and FMS just about a month and I have already experienced this same problems 2-3 times.  Do you really think I shall un-install and re-install FMS?  Let me know. Thanks!

             

            Jason

            • 3. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
              CampA
                

              HI tsturtle,

               

              Just checking back...any solutions?  I am still having the same problem on a weekly basis.

               

              Jason

              • 4. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                TSNanner
                  

                Hello CampA,

                 

                Do you know what version of Java is installed on the server machine? To check what version of Java is installed, do the following:

                 

                1. Go to Mac HD > Applications > Utilities > Terminal

                2. Type the following without quotes: "java -version"

                3. Copy the entire result and paste it in a reply post.

                 

                One thing you may want to check is that all the ports required for FileMaker Server are open for connection.

                You can find full list of ports and their purpose in Knowledge Base Article 6427: link

                To test if a port is open in the Mac OS:

                1. Go to Mac HD > Applications > Utilities > Network Utility
                2. Click the Port Scan Tab
                3. Enter the your IP address and only test ports between 16000 and 16018
                4. The results of the port scan should show something similar to this:

                Port Scan has started ...

                Port Scanning host: 172.16.21.67

                     Open TCP Port:     16000
                     Open TCP Port:     16001
                     Open TCP Port:     16012
                     Open TCP Port:     16016
                     Open TCP Port:     16018
                Port Scan has completed ...

                If it does not show Open TCP Port for all of the ports listed in the article, then the port may be closed. If you can reply back with what ports are not showing up we can troubleshoot from there.

                You may also want to check if there is a proxy server on your network, as all of Server's ports will need to be added as exclusions to the proxy server.


                TSNanner
                FileMaker, Inc.













                • 5. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                  CampA
                    

                  Hello!

                   

                  Thanks for your reply.  Here are the results of the two scans:

                   

                  XXXXXXXXXXXXXXXXX$ java -version
                  Shared archive: sharing disabled for server vm
                  java version "1.5.0_16"
                  Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
                  Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode)
                  XXXXXXXXXXXXXXXXX$


                  Port Scan has started ...

                  Port Scanning host: XXX.XXX.232.XXX

                       Open TCP Port:     16000
                       Open TCP Port:     16001
                  Port Scan has completed ...
                   

                  We don't use it for web server or web file sharing.  Do I still need to keep 16012, 16016 and 16018 ports opened?

                   

                  Let me know. Thanks!

                   

                  CampA








                  • 6. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                    cribscapes
                      

                    I am having exactly the same problem, but far more often.  3-5 times per day the Admin Console stops responding.  Force-Quit will kill it, but it will not reopen again without a full system reboot.

                     

                    We use this server for web connectivity through XML and it is accessed by half a dozen FMP10 or FMP9 clients as well.  The system does get very slow many times during the day, and when the slowness is apparent, we can't tell what might be causing it because the admin console is locked up.  After a while the system just speeds up to normal again. (Admin console still crashed). 

                     

                    FMSA10 on a 2 x 2.8 Quad Core Intel Xeon 6GB Ram

                     

                     

                    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)

                    Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing)

                     

                    Port Scanning host: 209.115.254.166

                     

                    Open TCP Port: 16000

                    Open TCP Port: 16001

                    Open TCP Port: 16012

                    Open TCP Port: 16016

                    Open TCP Port: 16018

                    Port Scan has completed ...

                     

                    Any help would be appreciated!

                     

                    Thanks,

                    Neil 


                     

                    • 7. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                      CampA
                        

                      Neil,

                       

                      I'm so glad that I am not alone.  Looks like we have the same java ver. which I believe is the latest.  I also have to Force-Quit it and restart the system since the Admin Console won't let me close files or stop the FM server.  

                       

                      Hope we will get some help soon.

                       

                      CampA

                      • 8. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                        cribscapes
                          

                        Let's hope it's just something simple!  Anyone else having the same trouble?  Speak up! 

                         

                        Neil 

                        • 9. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                          CampA
                             Just checking to see if you have found any solutions for us.  We are still having the same problem.  I have to restart the FileMaker Server after every weekend. It works fine during the week.  But for some reasons, it developed problems over the weekend, (may be no one was using it). On Monday, the server would stop responding or not running properly.  It kept disconnecting users.  I didn't have a choice but to reboot the Mac Server in order to correct the problem.  I really need a solution to fix this problem soon.  I don't want to have to restart the server every Monday. 
                          • 10. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                            cribscapes
                              

                            No solution yet, but...

                             

                            1) I have avoided the crashes by not using the Admin Console - ever.  As long as I never open the admin console, everything seems to work fine.  If I do have to use it, I reboot the machine afterwards. Talk about inconvienient!

                             

                            2) I have 'heard' that MacOSX 10.5.6 is the culprit.  I will try a downgrade to 10.5.4 this weekend and see what that gives me. I'll keep you posted.

                             

                            3) It has been my experience that when tech support stops talking to you, that you have a real bug on your hands. 

                              

                            • 11. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                              tannerellen
                                 I think I am having the same problem with my setup.  I wish there was an official response that FM Server does or doesn't have issues with 10.5.6.
                              • 12. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                                CampA
                                   I hope so too.  I need to restart our FMS and Mac OS Xserver on a weekly basis because of this problem.  It has been a real pain for us.
                                • 13. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                                  GH
                                    

                                  Same problem using Windows Server 2003 sp2.

                                  Console hangs up overnight when both a back up and verification routines are done. Server continues to work fine.

                                  I close files using DOS commands. Then reboot and console works till next day!

                                  Today, I reverted back to FMS8Adv, waiting for FM patch

                                  • 14. Re: FMS10Adv, Admin Console is not showing proper Clients status; server not responding
                                    TSGal

                                    All:

                                     

                                    Sorry for the late reply.  Communication Breakdown on our end here.  Nobody was looking at the Server board.

                                     

                                    First, a lot of these problems have been reported to our Development and Testing departments, but there are too many factors to determine what might be the possible cause.

                                     

                                    Regarding ports, please see Knowledge Base article #6427.  You can find it directly here:

                                     

                                    http://filemaker.custhelp.com/cgi-bin/filemaker.cfg/php/enduser/std_adp.php?p_faqid=6427

                                     

                                    On quite a few machines that exhibit this same sort of disconnecting problem, it turns out either the Admin Console has a screen saver or energy saver, which would directly interfere with the network connection, so please make sure to disable any of those options.

                                     

                                    In a cubicle near me, we have FileMaker Server 10 running on Mac OS X 10.5.1, and looking at the Log Viewer in Admin Console, it shows the Server was started January 2nd this year and no crashes since then.  So, it might be a Mac OS X 10.5.6 problem, but I cannot verify.  So, if you (cribscapes) can get back to us about your test with 10.5.4, that may help others.

                                     

                                    -------

                                     

                                    Still, with all of the above, we have received a number of Server problems with FileMaker Server 10 that we have been unable to identify.  What would be helpful to us is if you could supply us your FileMaker Server log files.  I have sent a private message (top of this screen - right side - X Messages) to "CampA", "cribscapes", "tannerellen" and "GH" with information where to send your log files.

                                     

                                    Again, I apologize for the lack of communication and dropping the ball. 

                                     

                                    TSGal

                                    FileMaker, Inc. 

                                    1 2 3 Previous Next