2 Replies Latest reply on Feb 8, 2011 5:23 AM by CraigSterling

    FMS11 database corruption on write and back-up

    CraigSterling

      Title

      FMS11 database corruption on write and back-up

      Your post

      I'll be as clear as I possibly can be.  

      We have 29 relational FM databases.  All users are on the current version of FMP 11 or FMPA 11.  The server is running the current FMS 11 version (11.0.2.217).

      These databases are mission critical to our organization and have been running virtually problem free since 1994!  Way to go FileMaker!

      However, yesterday, users started getting messages about databases closing after writing data to the files.  The Admin console would not allow me to open the databases.  Upon looking at the Log, the databases that closed had been damaged.  

      I closed all databases and stopped the server.  I then replaced the damaged databases using back-ups.  After restarting the server and opening the databases, the newly replaced back-ups would not open.  

      The process was repeated with earlier back-ups.  I ran consistency checks on the back-ups before replacing the corrupted versions. Some would not open when the server started.  Others did and then corrupted again later.

      I ran virus checks on all networked computers -all ok.

      I ran permission repair on the server mac- all ok.

      I ran hardware test and extended hardware test on the server mac (intel macpro 3,1 quad running OS X 10.5.8.

      Before leaving work late yesterday, I had all databases replaced with "good" files and appearing to function properly in the server - all listed as "open" and "normal".  Upon arriving this morning, three more were damaged per the log.  These three are still available to users. although I believe they will crash if users write to the files.

      Each file that has corrupted has had data written to it by clients prior to the corruption.  If it does not corrupt immediately, it corrupts on back-up.

      Your help is greatly appreciated.

      Craig Sterling

      U.S. Department of State