AnsweredAssumed Answered

FMSA 11 - Admin Console Unable to launch - Java Exception

Question asked by BenTrussell on May 29, 2011
Latest reply on May 31, 2011 by BenTrussell

Title

FMSA 11 - Admin Console Unable to launch - Java Exception

Your post

When I try to launch FileMaker Server 11's admin console from the start page on an up-to-date OS X 10.6.7 Desktop, the console fails to launch. 

Exception details from the desktop:

java.net.MalformedURLException: unknown protocol: httpss
    at java.net.URL.<init>(URL.java:574)
    at java.net.URL.<init>(URL.java:464)
    at java.net.URL.<init>(URL.java:413)
    at com.filemaker.adminconsole.ui.clients.AdminConsoleJnlpLauncher.main(AdminConsoleJnlpLauncher.java:131)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.sun.javaws.Launcher.executeApplication(Launcher.java:1909)
    at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1847)
    at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:1609)
    at com.sun.javaws.Launcher.run(Launcher.java:138)
    at java.lang.Thread.run(Thread.java:680)

Version of Java installed on both (from Apple->System Update):

java -version
java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07-334-10M3326)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02-334, mixed mode)

 

However I can indeed launch the console from the start page  on an up-to-date OS X 10.6.7 Server (? even though they both have the  same version of Java installed, the OS X default release for this  version).

I was seeing this before updating from v2 to v3, and on the server it works now, but not on the Desktop (tried on the desktop saving from firefox then launching, as well as running straight from Safari, neither works; I did also click 'trust' at indicated prompts for the Java bits).

There is a "httpss" unknown protocol message above, however its not a string found in the console app launher contents, and my versions of java on my desktop are the same as on the server. 

My question(s) (and if not in the right direction please correct):  Is there a reason why identical versioning leads to different results?  Perhaps a cache somewhere ?  Has anyone else encountered this Exception trying to launch the Admin Console?

Thank you in advance,

Ben

Outcomes