2 Replies Latest reply on Nov 2, 2010 12:07 PM by JohnArmstrong

    FMSA 11 - ODBC Syntax Error

    nateborland

      Title

      FMSA 11 - ODBC Syntax Error

      Your post

      After upgrading to FMSA 11 and installing the new ODBC driver, I am getting the following error whenever I try to run a query that worked fine in FMSA 10:

       

      "[FileMaker][FileMaker ODBC] FQL0001/(1:26): There is an error in the syntax of the query."

       

      Sad thing is that even a query like, "SELECT Company FROM Primary" is causing the problem.

       

      What can I do??

        • 1. Re: FMSA 11 - ODBC Syntax Error
          nateborland

          Got it resolved by adding quotes around the table names. The old ODBC driver wasn't picky on that, this one is.

          • 2. Re: FMSA 11 - ODBC Syntax Error
            JohnArmstrong

            I was having this problem as well with Apache Cayenne and FMP11. 

            For me it was strange, some objects failed on select and some did not, there was no particular reason why a specific object type would never let me query, it just would not and it failed with FQL0001/(1:25). It was consistent though (Object A always failed)

            In Cayenne 3.0 the devs added a 'Quote SQL Identifiers' option at the map level. Selecting this fixed it!

            Thanks nateborland, this was a satisfying end to a 4 hour ordeal.