AnsweredAssumed Answered

fmsadmin and fmserver

Question asked by AngeloMileto on Oct 13, 2008
Latest reply on Jan 8, 2010 by TSGal

Title

fmsadmin and fmserver

Your post

Alright. Managed to get my FM6 files converted, cleaned and opening error free so I figured lets get the server running.

 

After installing, I went through the config and tried to change the default folders as I already have a backup folder and I don't want the databases stored in the library. Everything I tried says it's an invalid folder so I checked the help and found this:

Tips for valid foldersThe folders you specify as a backup folder and as an additional database folder must be valid.

•Specify a folder on a local volume, not on a remote volume. If you want to store database backups on a remote volume, first backup the database to a local volume, and then copy the backup to a remote volume.

•Ensure that the folder has permissions set correctly so that FileMaker Server can read and write to the folder.(Mac OS) The folder must be owned by the user fmserver (or in the group fmsadmin).

•Specify the folder as an absolute path:

•Windows: The path you enter must start with filewin:/ and end with a slash (/).For example, filewin:/driveLetter/folderName/

•Mac OS: The path you enter must start with filemac:/ and end with a slash (/).For example, filemac:/volumeName/folderName/

 

Owned by fmserver or in the fmsadmin group? When I tried to change the permissions for my backup folder to add that group, it will not add as it doesn't seem to exist anywhere. When I just type in the name, it fails as I did not put in a password. What's up with this and how do I get it to work?

 
I've already uninstalled and reinstalled FM Server twice. When I check the permissions on the library folder, it does show the fmserver and fmadmin permissions. But, if I check the Users in System Preferences, neither one is there.
 
This was installed using the only user account that exists on the machine which is an admin account. Running on a Mini (1.83GHz Core 2 Duo) with 2GB of RAM and OSX 10.5.5. 

Outcomes