12 Replies Latest reply on Dec 31, 2012 1:55 PM by ericellis9

    Hiding a DB in the IWP Home Start Menu

    ericellis9

      Title

      Hiding a DB in the IWP Home Start Menu

      Your post

           Hi there...

           I have a number of DB's that are set up for IWP and served by FMP Server 12 advanced.  I am running Mac OS X ver 10.6.8. 

           A few of the DB's have IWP "turned on" only to access the data inside the DB.  I.E., I need to access data from DB "A" from DB "B".   DB "B" is hosted as an IWP, so in my experiance DB "A" also has to be hosted as an IWP DB.  However, I only want DB "B" to show in the IWP Home Start Up menu you get in the browser.

           Is there a way to keep a DB available as "IWP" but now have it show up in the start up menu?  I've searched the IWP documentation, WEB and this forum but had no luck...

           Thanks!

           Eric

        • 1. Re: Hiding a DB in the IWP Home Start Menu
          philmodjunk

               Won't you still be able to access the data via the IWP published Interface file even if the data file does not have IWP enabled?

          • 2. Re: Hiding a DB in the IWP Home Start Menu
            ericellis9

                 Hi Phil...

                 Thanks for the quick response!  Good question.  I modified the oringal post to read:

            A few of the DB's have IWP "turned on" only to access the data inside the DB.  I.E., I need to access data from DB "A" from DB "B".   DB "B" is hosted as an IWP, so in my experiance DB "A" also has to be hosted as an IWP DB.  However, I only want DB "B" to show in the IWP Home Start Up menu you get in the browser.

                 SO I think the DB needs to be turned on for IWP - I just don't want it to sho up in the list.  I'm pretty sure I read somewhere where you could pick and choose which DB's show up on the menu, but can't find it now!

                  

            • 3. Re: Hiding a DB in the IWP Home Start Menu

                   Eric Ellis:

                   Thank you for the post.

                   To keep the database from displaying on the Instant Web Publishing start page:

                     
              1.           Open the database locally with FileMaker Pro.
              2.      
              3.           Click > File > Sharing > Instant Web Publishing
              4.      
              5.           Check the box for "Don't display in Instant Web Publishing homepage." 

                    

                   See the screenshot attached below. This is also documented on page 29 of the FileMaker Pro 11 Instant Web Publishing Guide and page 30 of the FileMaker Pro 12 Instant Web Publishing Guide.

                   TSFalcon
                   FileMaker, Inc.

                    

              • 4. Re: Hiding a DB in the IWP Home Start Menu
                ericellis9

                     Hi TS...

                     Thanks for that.  I have tried to set that setting but could never get the IWP turned "On".  I think my problem is that the DB is on the server machine and I am opening it from another machine, not locally.  I will ask my IS department to get FMP CLient installed on the server maching so I can open it locally, and then see if I can set it on.

                      

                     Thanks!  I'll keep you posted...

                      

                     E

                • 5. Re: Hiding a DB in the IWP Home Start Menu

                       Eric Ellis:

                       If FileMaker Pro's Instant Web Publishing feature is turned on while on the same machine running FileMaker Server, then the error in the screen shot below will be seen. 

                       Make the change locally on a computer with the FileMaker Pro client that doesn't have FileMaker Server installed, and then re-upload the file to the server. If that doesn't resolve the issue, let me know and we will discuss further troubleshooting. 

                       TSFalcon

                       FileMaker, Inc.

                  • 6. Re: Hiding a DB in the IWP Home Start Menu
                    ericellis9

                         Hi there...

                         First of all, thank you so much for your help here.

                         So I copied the DB over to a local machine, and then opeend it with FMP12 - when I tried to select the "Instant Web Publishing" in the sharing option, I get the mesaage below.

                         Any ideas?

                         Eric

                    • 7. Re: Hiding a DB in the IWP Home Start Menu

                           Eric Ellis:

                           Thank you for the prompt reply.

                           Is Instant Web Publishing Instant Web Publishing could not be started of FileMaker? Do you receive that error when turning on Instant Web Publishing on any file while logged in as the Instant Web Publishing could not be started using FMP Advanced 10.0v3 Mac OS X 10.6.4

                           The installation may also be corrupted and the solution might be to filemaker cannot share files over the web because instant web publishing could not be started. Make sure to backup any databases first and trash the entire FileMaker Pro directory folder. If Instant Web Publishing still fails to an error after reinstalling, try installing under a new user account or try an installation on another computer. 

                           Let me know if theses steps resolved the issue.

                           TSFalcon
                           FileMaker, Inc.

                            

                      • 8. Re: Hiding a DB in the IWP Home Start Menu
                        ericellis9

                             Hi here...

                             A few questions:

                             1.  When you say "is it turned on in an earlier version", I'm not sure how to check that.  We were running the DB's in FM 11 before updating to FM12.  I'm not sure how to check if it's still turned "On" in FM11.  For example, I can't open the DB in FM11, right?

                             2.  In terms of logging in, the administrator user who created the original DB (that I am trying to stop from showing in the IWP menu) is not the same user who installed FM11 or FM12.  I added that user to the security of the DB and then tried to open it with that user, but still could not start IWP.  Should I have done something differently?

                              

                             Thanks again for you help...

                              

                             e

                        • 9. Re: Hiding a DB in the IWP Home Start Menu

                               Eric Ellis:

                               Thank you for the post.

                               You are correct that a .fmp12 file cannot be opened with FileMaker Pro 11. However, if a .fp7 file is currently open and being hosted with FileMaker Pro 11, then FileMaker Pro 12 will give the error in your screenshot when trying to turn Instant Web Publishing to ON. If FileMaker Pro 12 is the only version of FileMaker running on the machine, then that isn't the issue. If this is the only installation of FileMaker Pro, you may want to reinstall. 

                               Any full access account can modify the account privilege set, enable or disable Instant Web Publishing for the file, or check the option box.

                               Try to open a copy of the file locally on the machine, turn on Instant Web Publishing and check the box. Afterwards, re-upload the copy to the FileMaker Server and the file should not "display in the Instant Web Publishing homepage."

                               TSFalcon

                               FileMaker, Inc.

                          • 10. Re: Hiding a DB in the IWP Home Start Menu
                            ericellis9

                                 Hey there...

                                 Thanks for the info.  Yea,  I don't have any other DB's running but FM12, so I guess that is not the problem.  I'm still back to square one - I take a copy of the DB locally, try to select IWP under the sharing option, and I get the message shown earlier in the post.

                                 Do you think my next step should be installing FM12 again?  BTW, I am using FM12 Advanced on my machine (Version 12.0v2).

                                 e

                            • 11. Re: Hiding a DB in the IWP Home Start Menu

                                   Eric Ellis:

                                   Thanks for the prompt reply.

                                   You could try updating first to FileMaker Pro Advanced 12.0v3:

                              Software Update: FileMaker Pro 12.0v3 and FileMaker Pro 12.0v3 Advanced

                                    

                                   If the only installation of FileMaker is the copy of FileMaker Pro 12 Advanced and after the update you continue see the error "Instant Web Publishing could not be started," then I would uninstall and reinstall the program. 

                                   If the issue persists after the reinstall, then try another user or another computer. 

                                   Please let me know the results of your troubleshooting and if additional assistance is required. 

                                   TSFalcon

                                   FileMaker, Inc.

                              • 12. Re: Hiding a DB in the IWP Home Start Menu
                                ericellis9

                                     Hi TS...

                                     I will work with our IS department to get FMP upgraded.   Once I get that done, I will try agani and see what happens.  I'll  keep you posted...

                                     Eric