5 Replies Latest reply on Aug 15, 2011 3:53 PM by TSDuck

    I don't think Web Server is really running with FM 11 Server Advanced

    JamesStrickland

      Title

      I don't think Web Server is really running with FM 11 Server Advanced

      Your post

      I recently installed FM 11 Server Advanced on my W2K3 x64 machine. According to the FMS Admin Console the Web Server and Web Publishing Engine are both up and running properly. However, I am not able to access them in any way.

      When I look in the W2K3 event viewer I see the following error messages:

      Could not load all ISAPI filters for site/service. Therefore startup aborted.

      A process serving application pool 'DefaultAppPool' reported a failure.

      I also get the following from the FMS logs:

      2010-09-01 09:53:51    Publishing Engine    Information    FM Web Publishing - - wpc1 FileMaker Server Web Publishing Engine started.

      2010-09-01 09:53:51    Publishing Engine Access    Error    127.0.0.1:2409 - - "/fmi/conf/config.wpc?-iwp_enabled=yes" 401 0

      2010-09-01 09:53:51    Publishing Engine Access    Information    127.0.0.1:2410 - fmsadmin "/fmi/conf/config.wpc?-iwp_enabled=yes" 200 2244

      2010-09-01 09:53:53    Publishing Engine Access    Error    127.0.0.1:2416 - - "/fmi/conf/config.wpc" 401 0

      2010-09-01 09:53:53    Publishing Engine Access    Information    127.0.0.1:2417 - fmsadmin "/fmi/conf/config.wpc" 200 2244

      I would appreciate any help I can get in finding out what is going on.<!-- <!  table      {mso-displayed-decimal-separator:"\.";      mso-displayed-thousand-separator:"\,";} td      {padding-top:1px;      padding-right:1px;      padding-left:1px;      mso-ignore:padding;      color:windowtext;      font-size:10.0pt;      font-weight:400;      font-style:normal;      text-decoration:none;      font-family:Verdana;      mso-generic-font-family:auto;      mso-font-charset:0;      mso-number-format:General;      text-align:general;      vertical-align:bottom;      border:none;      mso-background-source:auto;      mso-pattern:auto;      mso-protection:locked visible;      white-space:nowrap;      mso-rotate:0;} .xl24      {mso-number-format:"General Date";} ruby      {ruby-align:left;} rt      {color:windowtext;      font-size:8.0pt;      font-weight:400;      font-style:normal;      text-decoration:none;      font-family:Verdana;      mso-generic-font-family:auto;      mso-font-charset:0;      mso-char-type:none;      display:none;}  > -->

        • 1. Re: I don't think Web Server is really running with FM 11 Server Advanced

          James Strickland:

          Thank you for posting.

          It appears there are some 401 (Unauthorized) errors which usually indicate an authorization issue within IIS. Please follow the instructions regarding anonymous access on page 64 of the FileMaker Server 11 Getting Started Guide:

          http://www.filemaker.com/support/product/docs/fms/fms11_getting_started_en.pdf

          What is the exact result when you navigate to http://serverNameOrIP/fmi/iwp ?

          Have you tried resetting IIS to the default configuration and then redeploying the web publishing?

          If this is the 64-bit version of 2003 Server there could be a compatibility issue as well.

          TSuki
          FileMaker, Inc.

          • 2. Re: I don't think Web Server is really running with FM 11 Server Advanced
            JamesStrickland

            anonymous access is already set up.

            When navigating to http://serverIP/fmi/iwp I get a blank page with "Service Unavailable".

            I reset IIS to the default configuration. I'm not sure how to redeploy web publishing. I see how to turn it off and back on. When I do that, my browser says the page cannot be found.

            • 3. Re: I don't think Web Server is really running with FM 11 Server Advanced
              JamesStrickland

              I did figure out how to redeploy the web publishing. However, after all of that, I still get the same "Service Unavailable"

              • 4. Re: I don't think Web Server is really running with FM 11 Server Advanced
                user6385

                Hello,

                I have the same error.

                Congiguration : FMS adv 11 v02, Java 6.20, Bonjonjour 2.0, two uptodate Windows Server 2008 R2 VMWare, deployment 2 machine alternative, worker on dmz with only IIS v 7.5.76 and Web Server Module (only IWP enabled), master with WPE and DB (FileMaker test deployment file). All windows firewall disabled and all ports open on servers. Port 16000, 16016 and 16018 open through a Netstat firewall in both directions between dmz and lan. Test scanport OK.

                On IIS, anonymous access is set up (default configuration). The getting start manuel p64 is not uptodate for IIS v7.5.76, i am not sure what settings about authenticated method acces. Actually, basic authentication is disable (stimulation HTTP 401), and i think i'ts ok, but if anyone knows, i thank in advanced.

                During deployment, the master made installation of web part on IIS without problem, but it doesnt lauch WPC

                Server master logs are the same than James :

                2010-09-01 18:12:28    Acces moteur de publication    Erreur    127.0.0.1:59809 - - "/fmi/conf/config.wpc?-iwp_enabled=yes&-xml_enabled=no&-php_enabled=no&-language=fre&-xslt_enabled=no" 401 0
                2010-09-01 18:12:34    Acces moteur de publication    Erreur    127.0.0.1:59822 - - "/fmi/conf/config.wpc" 401 0

                When i trie to open the file test with my browser, blank page without message.

                I have done numerous installation uninstall on both servers and clean-directories FileMaker, same results.

                I put my web server on lan, uninstall/install, no change.

                In the next three  months, we have to deploy six identical configurations, and I am very  worried when the reliability of IWP with FMS11.

                Thank you for the help you can give us


                • 5. Re: I don't think Web Server is really running with FM 11 Server Advanced
                  TSDuck

                  Hi Jeff Berthelot:

                  Thanks for posting.

                  The issue you are having could be related to the 32 bit ISAPI extension not being installed and the 32 bit application pooling being disabled.  Please try these steps in IIS to help resolve your issue.

                   

                  Enabling ISAPI filters and ISAPI extensions

                  1. Choose Control Panel > Programs and Features.

                  2. Open Server Manager.

                  3. Expand Roles in the left pane, then select Web Server (IIS).

                  4. In the right pane, click Add Roles Services in the Role Services section.

                  5. Select ISAPI Filters and ISAPI Extensions in the Application Development section, then click Next and Install.

                  6. After the installation is completed, restart the computer.

                   

                  Enabling application pooling compatibility with 32-bit applications:

                  1. Choose Control Panel > Programs and Features.

                  2. Open Server Manager.

                  3. Expand Roles in the left pane, then expand Web Server (IIS) and select Internet Information Services (IIS) Manager.

                  4. In the Internet Information Services Manager pane, expand your web server name and select Application Pools.

                  5. In the Application Pools pane, select DefaultAppPool and click Set Application Pool Defaults in the Actions pane.

                  6. In the Application Pool Defaults dialog box, select Enable 32-bit Application and change the value to true, then click OK.

                  7. Right-click DefaultAppPool in the Application Pools pane, choose Stop and then choose Start from the context menu.

                  8. Verify that there were no errors in starting the application pool.

                  9. Close the Server Manager windows and then exit Server Manager.

                  You will need to redeploy FileMaker Server after following these steps.

                   

                  TSDuck

                  FileMaker, Inc.