9 Replies Latest reply on Aug 11, 2010 12:50 PM by lwood

    Images in Container field not showing in IWP

    ScottGross

      Title

      Images in Container field not showing in IWP

      Your post

      We are running FMS Advanced 9 on OSX.

       

      I am linking PDF files with a relative link into our database. The PDF files reside on a different server than the database file. When viewed natively in FM Pro Advance 9 everything show up just fine and even refreshes when the pdf is updated. However, when viewed in a web browser with IWP the pdf images do not show up.

       

      Any ideas?

        • 1. Re: Images in Container field not showing in IWP
          kapitaen_1

          you have to make sure that the iwp server and / or client (i didnt test it yet) can see the folder where the media files are stored can bee seen under exactly the same path as the client which did enter the media files to filemaker.

           

          or...

           

          all media files must be inserted directly (not as link).

           

          greetings from germany

          chris

          • 2. Re: Images in Container field not showing in IWP
            ScottGross

            The iwp server and all clients (MAC & PC) have the source fileserver mounted. If I use filemaker on a client machine everything shows just fine. When I use a browser & IWP through a client machine I loose the link and image in the container field. Directly inserting the files into the database is not an option as there are thousands of files and the database would get to large in file size.

            • 3. Re: Images in Container field not showing in IWP
              davidhead

              May be useful to read the IWP guide.

               

              It notes "If you’re hosting the database with FileMaker Pro, referenced image and movie files must be stored in the Web folder, in the FileMaker Pro folder."

               

              And then when hosting with FileMaker Server Advanced:

               

              "Move the contents of the Web folder to the root folder of the web server software. Make sure the relative path is preserved.

              ForIIS, move the files to: <root drive>\Inetpub\wwwroot

              For Apache, move the files to: /Library/WebServer/Documents"

              • 4. Re: Images in Container field not showing in IWP
                ScottGross

                We are hosting with FileMaker Server Advanced 9 on a mac and using IWP.

                 

                Is there no way around our relative linked files being place in /Library/WebServer/Document?

                 

                We have ten designers placing files and pdfs on a separate fileserver on our network. The files are constantly changing and I would like to link to the pdfs (relative) so that when they are updated by the designers it is automatically updated in IWP. This set up works great with FMP Clients but it is not in the budget to get everyone their own copy of FMP (which is why IWP looks like a good option).

                 

                In the mean time, I have tried a sample setup with the pdfs in /Library/WebServer/Document but it is not working.

                 

                Linked files show the FM path of "imagemac:/Macintosh HD/Library/WebServer/Documents/apache_pb.gif"

                but the browser html is looking at the path of <img src="Server/Documents/apache_pb.gif"

                 

                As you can see, IWP is stripping "Web" off of "WebServer" in the path and breaking the link.

                • 5. Re: Images in Container field not showing in IWP
                  TSGal

                  Scott Gross:

                   

                  Thank you for your posts.

                   

                  Referenced Image files must be in the Web folder in the FileMaker Pro/Server directory.

                   

                  Please see Knowledge Base Article #5812 for more information:

                   

                  http://www.filemaker.com/support/kb/?answers/detail/a_id/5812

                   

                  TSGal

                  FileMaker, Inc.

                  • 6. Re: Images in Container field not showing in IWP
                    ScottGross

                    I have done that but this is what is happening.

                     

                    Linked files show the FM path of "imagemac:/Macintosh HD/Library/WebServer/Documents/apache_pb.gif"

                    but the browser html is looking at the path of "img src="Server/Documents/apache_pb.gif"

                     

                    As you can see, IWP is stripping "Web" off of "WebServer" in the path and breaking the link.

                    • 7. Re: Images in Container field not showing in IWP
                      TSGal

                      Scott Gross:

                       

                      FileMaker Pro appears to be stripping anything following "Web".  However, the issue is still the same.  You do not have the file in the Web folder.  Place the image there and link it.

                       

                      TSGal

                      FileMaker, Inc.

                      • 8. Re: Images in Container field not showing in IWP
                        ScottGross

                        In the IWP Guide it states:

                         

                        And then when hosting with FileMaker Server Advanced:

                         

                        "Move the contents of the Web folder to the root folder of the web server software. Make sure the relative path is preserved.

                        ForIIS, move the files to: <root drive>\Inetpub\wwwroot

                        For Apache, move the files to: /Library/WebServer/Documents"

                         

                        We are using FileMaker Server Advanced. Do we also have to install FileMeker Pro on the server machine and store the files in the "Web" folder as well as  /Library/WebServer/Documents

                        • 9. Re: Images in Container field not showing in IWP
                          lwood

                          Hi,

                          I'm having the same issue, trying to get PDF's to show in IWP, they are located in the "Web" folder inside FM Pro folder, doesn't matter if the PDF is referenced or stored, the only way I can get the image to show up is to re-save it as jpeg.

                          Using FM Pro 9, FireFox as browser, Mac OSX 10.5.8.

                          Would much prefer to have the PDF's link correctly than having to take the extra step of re-saving as jpeg, but at least there's an image to view using IWP.

                          Thanks

                          Lee