9 Replies Latest reply on Feb 17, 2015 10:49 AM by dddan

    install FMS 13 test of web server fails: port 80 connection refused

    ceath

      Title

      install FMS 13 test of web server fails: port 80 connection refused

      Your post

      Excuse my stupidity on this one, but a simple problem has me stumped.

      I'm installing FileMaker Server 13 on a new Mac Mini.  I'm going through the Deployment Assistant, and get stuck on step 5.  The IP address of the host is the IP address of the Mac Mini and the connection attempt is HTTP on port 80.  I get a message: "Test web server (http://127.0.0.1:80/fmi-test/test.xml): Connection refused"

      I have my router (I'm using a Time Capsule) to do NAT port forwarding -- ports 80, 443, 5003 (for FileMaker) and 8020 (for 360Work SuperContainer) are all forwarded to the IP address of the Mac Mini.  Yet a port scan (using Network Utility), I only find port 88 open.  I'm thinking this is where the problem lies, but I'm not sure.

      Any suggestions for why a connection on port 80 would be refused?  This is a new Mac Mini with nothing but FileMaker Server 13 loaded on it.

      Thanks,

      Martin Ramsay

       

      Stuck_on_step_5.png

        • 1. Re: install FMS 13 test of web server fails: port 80 connection refused
          ceath

          More information:

          On an older Mac Mini (at IP 10.0.1.15), several ports are open.  Using the Network Utility to do a port scan, here is a list of the open ports between 0 and 8020:

          Port Scanning host: 10.0.1.15

               Open TCP Port:     80             http

               Open TCP Port:     88             kerberos

               Open TCP Port:     106            3com-tsmux

               Open TCP Port:     389            ldap

               Open TCP Port:     443            https

               Open TCP Port:     445            microsoft-ds

               Open TCP Port:     464            kpasswd

               Open TCP Port:     548            afpovertcp

               Open TCP Port:     625            dec_dlm

               Open TCP Port:     749            kerberos-adm

               Open TCP Port:     2002           globe

               Open TCP Port:     3659           apple-sasl

               Open TCP Port:     3999

               Open TCP Port:     5003           fmpro-internal

               Open TCP Port:     5013

               Open TCP Port:     5015

               Open TCP Port:     5900           rfb

               Open TCP Port:     8020           intu-ec-svcdisc

          Port Scan has completed…

           

          My new Mac Mini (at IP 10.0.1.14) has a lot fewer ports open:

          Port Scanning host: 10.0.1.14

               Open TCP Port:     88             kerberos

               Open TCP Port:     5003           fmpro-internal

               Open TCP Port:     5013

               Open TCP Port:     5900           rfb

          Port Scan has completed…

           

          The old Mac Mini is still running Mavericks while the new one is running Yosemite.  Is there a difference between how the two OS versions handle port blocking?  Both servers have their firewall turned off, so I don't think the problem lies there.  Because port 5003 is open on the new server, it looks like the FileMaker Server install did open that port at least.

          • 2. Re: install FMS 13 test of web server fails: port 80 connection refused
            ceath

            Even more information:

             

            I am able to do a successful install of FileMaker Server if I skip the installation of WebDirect.  So FileMaker Server is up and running.  But ... for my application, Web Direct is the whole reason for deploying FileMaker Server in the first place.

            So my next step was to go back and attempt to install Web Direct after the fact.  In the FileMaker Admin console, I went to Server --> Edit Deployment.  This time I selected "Yes, enable web publishing" and checked "FileMaker WebDirect".  (See the screen shot.)

            Yet I still receive the same message:  "Test web server (http://127.0.0.1:80/fmi-test/test.xml): Connection refused".  And the screen shot looks the same as what I had uploaded earlier.

            So, even though FileMaker Server is successfully installed, I'm still not able to deploy WebDirect because of some problem on port 80.

            Any ideas would be most appreciated.

            • 3. Re: install FMS 13 test of web server fails: port 80 connection refused
              ceath

              Looking at the recommendations that TSGal made to seevogel here, I performed a simple test.  I entered http://10.0.1.14 (the IP address where FileMaker Server is deployed) and got a "can't connect to the server" message.  So that tells us that, indeed, port 80 (and 443) are not available.  But I don't know how to make them available or bind them to fmserver.

              • 4. Re: install FMS 13 test of web server fails: port 80 connection refused
                RickWhitelaw

                Do the port forwarding on the router "connected to the wall" and not the Time Capsule. Use the Time Capsule in bridge mode.

                • 5. Re: install FMS 13 test of web server fails: port 80 connection refused
                  ceath

                  Thanks, Rick.  That would be one approach, but I don't think that gets at the root of the problem.

                   I have a DSL "modem" at the wall in bridge mode and use the Time Capsule to do port forwarding.  I have two servers, we'll call them "old" and "new."  Each has their own assigned IP address using NAT in the Time Capsule.  When I do port forwarding to the "old" server, everything works fine.  Then I take it off line, redo the port forwarding in the Time Capsule to redirect the appropriate ports to the IP address of the "new" server, and FileMaker has a conflict on port 80.  

                  So I think the issue is on the "new" server -- something is locking port 80 so that FileMaker can't use it for WebDirect.

                  • 6. Re: install FMS 13 test of web server fails: port 80 connection refused
                    Tsongming

                    Hi Martin,

                    Unplug or disable your computer from the network and finish the installation...offline. 

                    If you have followed the getting started guide; you might have a duplicate TCP IP addresses. Follow the step by step instructions in the getting started guide here: https://fmhelp.filemaker.com/docs/13/en/fms13_getting_started.pdf.

                    Additionally, your port forwarding setup is not correct.

                    You can review the KB : http://help.filemaker.com/app/answers/detail/a_id/9770/~/port-forwarding-information. for port forwarding requirements.

                    Finally, is this a dedicated machine? Do you have OX Server software installed? > if so remove it.

                    Are you sharing other programs from this computer?

                    Did you setup a static TCP address for your FMS13 install?  

                     

                    • 7. Re: install FMS 13 test of web server fails: port 80 connection refused
                      aauv

                      Mi, Martin,

                      when you uninstall FileMaker Server by means of the uninstall option (of the install app), FileMaker Server is not completely installed: The folder «/Library/FileMaker Server» remains, and this is causing the problem!

                      Move your precious databases which reside in the folder «/Library/FileMaker Server/Data/DataBases» to a safe place, and delete the folder «/Library/FileMaker Server» before reinstalling FileMaker Server.

                      That should do it.

                      • 8. Re: install FMS 13 test of web server fails: port 80 connection refused
                        ceath

                        Thanks to both Tsongming and to Ulrich Vielhauser!

                        Tsongming, I tried the clever idea of doing the installation off line.  I like that approach as it completely eliminates potential problems caused by conflicting IP addresses, NAT and port forwarding.  Unfortunately, I got the same result.

                        I'm pretty sure my port forwarding for my old Mac Mini was correct because WebDirect worked as expected when accessing the server from the Internet.  All I did in the port forwarding table was change the target IP address to the new computer.  Unless there is an additional port required by FileMaker Server 13.0v5 Yosemite that 13.0v3 does not require under Mavericks, I doubt this is the source of the issue.

                        For the record, the new Mac Mini I'm attempting to do the install on is a new, just-out-of-the-box computer that is NOT running Server or anything else.  I bought it in December for this sole purpose.

                        Ulrich, thanks very much for your suggestion.  I did not know that the FileMaker-provided uninstall does not completely clean up after itself.  I had initiated a complete reinstall of Yosemite 10.10.1 on the computer before I saw your post, so I think that issue is moot now.  But I'll remember that for the future should I need to do an uninstall again.

                        Thanks to both of you for all your support and concern.  I'm pulling out what little hair I have left and your suggestions keep giving me the incentive to keep trying!

                        • 9. Re: install FMS 13 test of web server fails: port 80 connection refused
                          dddan

                          Hi, was wondering if you ever got it to work. I had to update my FM Server Mac to Yosemite and I got the same error. (connection refused) I can install and deploy FM Server 13.05 without a problem, I just can't enable web services. I did a lot of testing, de-installed, removed the FM server folder, etc. Re-installed, etc. (when I re-install I did get the message port 80 and 443 are in use, and did choose disable web sites) Also tried port 591 as suggested by FM, same error. (also tried 8000, to be honest I don't care on which port it is web serving, I can remap that in the router)

                          The problem seems to lie in Yosemite switching off access to port 80 (and others). I also have Apple Server Tools so I tried the following: I switched on Web services and then I can access the ports on my local network and you get the default website.

                          When I try to deploy FM Web direct then, I get the correct 404 error because the ports are in use (by Apple's web services) When I switch off web services again then I get error 403 (instead of connection refused) but that means almost the same. (forbidden) 

                          When I then try to access port 80 from my local network it says 'websites are turned off'. kind of suggesting that the ports are closed on the server now.

                          Please note it is not a firewall issue, I am deploying FM Server from the same mac as it is running. (localhost) I have no (software)FW enabled on that Mac. I guess I am looking for a unix command to tell Yosemite that it should allow access of ports 80 and 443...

                          Any suggestions, work around, unix commands are appreciated... I have wasted almost a day now... 

                          Daniel