0 Replies Latest reply on Apr 21, 2010 1:08 PM by RolandT

    Instant webpublishing: internal error popup

    RolandT

      Title

      Instant webpublishing: internal error popup

      Your post

      Hello,
       
      We are running a database for a at least a year, and notting changed (except data).
      When we are working in the database via instant web publishing everything is working, but an instant later we get an internal error popup "An internal server error has occurred." with an oke button. I get this error popup on every field on the screen. When i Oke all the errors, then i can relogin to the database.

       
      We tried: 
      - recover the databases
      - create a clone of the recover databases
      - imported the data of the recovered tables in the clone
      result: same error
      - installed fmserver on a different Mac-server. Running the databases > Same internal error 
      - installed fmserver 10 (latest) on the other mac-server. > same internal error
      - imported the data in an old backup > same internal error
      - deleted a graphics in the database > same internal error
       
      I found in the link below, that the error is an javascript error of the javascripts that iwp uses.
      http://etutorials.org/XML/filemaker+pro+6+developers+guide+to+xml_xsl/Chapter+5+XML+and+FileMaker+Pro+Web+Publishing/5.5+Error+Codes+for+XML/

       
      I found the 500 error in the log (see below) :
      217.118.162.245 - - [07/Dec/2009:17:49:23 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.245 - - [07/Dec/2009:17:49:50 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/res/iwp_home.html HTTP/1.1" 200 6275
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/cgi?-dblinks HTTP/1.1" 200 628
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/cgi?-getstrings HTTP/1.1" 302 -
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/res/eng/strings.js HTTP/1.1" 200 5553
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/res/images/iwp_banner.gif HTTP/1.1" 200 12955
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/res/iwp_home.css HTTP/1.1" 200 1638
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/res/images/iwp_home.gif HTTP/1.1" 200 868
      217.118.162.244 - - [07/Dec/2009:17:54:31 +0100] "GET /fmi/iwp/res/images/iwp_logo.gif HTTP/1.1" 200 1207
      217.118.162.244 - - [07/Dec/2009:17:54:32 +0100] "GET /fmi/iwp/res/images/iwp_db.gif HTTP/1.1" 200 1185
      217.118.162.244 - - [07/Dec/2009:17:54:57 +0100] "GET /fmi/iwp/cgi?-db=Guru&-startsession HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:02 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:03 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:06 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:13 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:14 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:19 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:20 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      217.118.162.244 - - [07/Dec/2009:17:55:21 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240
      85.144.112.201 - - [07/Dec/2009:17:55:26 +0100] "GET / HTTP/1.1" 304 -
      85.144.112.201 - - [07/Dec/2009:17:55:27 +0100] "GET /fmi/iwp/cgi?-db=Guru&-startsession HTTP/1.1" 500 9240
      85.144.112.201 - - [07/Dec/2009:17:55:30 +0100] "GET /fmi/iwp/cgi?-open HTTP/1.1" 500 9240 
       
      Can somebody help me?