3 Replies Latest reply on Jun 19, 2015 12:57 PM by deadboltsecurity

    Invalid Username/Password Combo when attempting to upload file

    mattsteam

      Title

      Invalid Username/Password Combo when attempting to upload file

      Your post

      Hi All,

      I'm running across an error message telling me I'm giving an Invalid name/password when attempting to upload a file to my FM14 server.  I've verified I am using in the correct username and password as I am able to log into the admin console.  I've tried it both from a remote machine and the actual machine.

      Anyone else run into this or have a clue what could be happening?

      System:

      FileMaker Server 14.0.2.226

      Windows Server 2012 R2

      Nothing else is running on the machine.

        • 1. Re: Invalid Username/Password Combo when attempting to upload file
          deadboltsecurity

          Don't have a solution to your problem but I can certainly empathize as your problem seems to be very similar to mine. I would recommend posting this question in the FM Server Forum rather than the FM Pro Forum. Might get a quicker answer

          I have FM Server 14. Was working perfectly until about 4-5 days ago. Here's what I noticed on the server...

                 
          • From the DB server machine, I can go to http://localhost:16001/admin-console and the console works works fine.
          •      
          • If I "Upload to FileMaker server" I get an "invalid id or password" message.
          •      
          • If I manually copy the file to my database server, it hosts the file just fine.
          •      
          • On the server console under "Status" it shows "Web Server" as grayed out. Nothing I've done seems to change that.
          •      
          • From the FM server console, if I "Open Start page..." from the "Server" tag at the top of the page, I get "secure connection failed" and it's URL is https://192.168.1.51:16000/index.html
          •      
          • If I change the HTTPS to HTTP I get "The connection was reset"
          •      
          • Accessing the management console with HTTPS using the 16000 port, I get a "Secure Connection Failed".
          •      
          • If I change the port number to my HTTP port (mine is on port 16001) I get an "Unable to connect"
          •      
          • If I "Open test page", I get the same HTTPS failure of "Secure Connection Failed".
          •      
          • If I edit it to be HTTP on either 16000 or 16001, I get failure messages.

          On the remote computer...

          I've looked through all my FM server setting. Again, NO changes made to this machine from the day before when it worked perfectly. No maintenance. No updates. No configuration changes. It just woke up in the morning be all screwed up.

          I've telneted into the problematic IP and ports and all respond properly. Double checked all the IIS setup and it's been tested and working fine. Only things that get passed off to the FM Server process no longer work.

          For one, I'm going to just reinstall FM Server and see what that gets me. I'll update this as well just in case it helps someone else.

          Kevin

          • 2. Re: Invalid Username/Password Combo when attempting to upload file
            deadboltsecurity

            Further background...

                   
            • Ran NetStat to see if I had port/IP conflicts. I didn't.
            •      
            • In IIS, I added a simple "test.txt" to the FMS web site. It pulls up just fine so IIS is serving it out correctly.
            •      
            • Of course I've double checked passwords and even changed the password on the server. No change.
            •      
            • I set up an "Administration Group" and those credentials fail as well when trying to upload a new FM database.
            •      
            • ALL FM Go and FM Pro, both Mac and PC can work with the DBs on the server from within FM Pro.
            •      
            • Noticed when I turned on full, max logging the failed connection for uploading a DB do NOT even register.

            Hope that helps.

             

            • 3. Re: Invalid Username/Password Combo when attempting to upload file
              deadboltsecurity

              See my thread at https://community.filemaker.com/thread/85240?sr=stream

              Essentially did a reinstall and it works now. Not an ideal answer but it worked and took less time than all the other messing around I was doing.

              Kevin