1 Reply Latest reply on Jun 13, 2010 5:24 PM by mikeryan

    Manually install FileMaker API for PHP on Mac OS X Snow Leopard Server 10.6.3

    mikeryan

      Title

      Manually install FileMaker API for PHP on Mac OS X Snow Leopard Server 10.6.3

      Your post

      First, please note I'm obviously a rookie. When I run the "Test PHP Custom Web Publishing" the result is a blank browser page.

       

      I installed FM Server on Mac OS X Snow Leopard Server 10.6.3 without the FileMaker version of PHP.

       

      Per the FileMaker Server 11 Custom Web Publishing with PHP document:

       

      I extracted "a file called FileMaker.php and a folder called FileMaker" from the standalone zip file that was located at /Library/FileMaker Server/Web Publishing/FM_API_for_PHP_Standalone.zip.

       

      I put both the file and folder in this location: "/Library/WebServer/Documents".

       

      Now, here's where I think I have a problem. The following instructions tell me to make some changes to php.ini:

       

       

      If you did not install the FileMaker supported version of PHP, be sure to do the following configuration tasks on your version of the PHP engine:

      - Enable the cURL module in php.ini.

      - Specify the location of the FileMaker API for PHP in the include_path variable in php.ini.

      - If you are accessing databases that contain dates and times, install the pear date package. For more information, see: http://pear.php.net/package/date/

       

       

      Where do I find php.ini?

       

      Thanks,

      Mike

        • 1. Re: Manually install FileMaker API for PHP on Mac OS X Snow Leopard Server 10.6.3
          mikeryan

          Got it!

           

          php.ini is located at "/etc" (along with three other files named php.ini.applesaved, php.ini.default, and php.ini.server-default, by the way).

           

          Also, by the way, I found this location from the command line (Terminal) by typing "cd .." until I was at the root of "Server HD", then used "ls" to work my way back down and find the file. It seems the folder "/etc" is really an alias to "/private/etc" which is where the php.ini file lives.

           

          Although the Finder normally won't show these invisible folders and files, and Spotlight doesn't find them, I've since discovered that if you know where the folder is then you can use Finder's "Go to Folder..." menu item to see it.

           

          So... I used TextWrangler to add the line include_path = "/Library/WebServer/Documents/" to php.ini.

           

          I found that cURL was already enabled.

           

          The version of PHP installed with Snow Leopard Server is 5.3.1.

           

          Finally, now the test page loads successfully.

           

          One remaining possible problem is that I haven't addressed this statement:

           

          "If you are accessing databases that contain dates and times, install the pear date package."

           

          Hopefully, as with the cURL thing, it's a non-issue. I really don't want to have to figure out what the heck it takes to do this. And, I do need to work with dates. So, we'll see...


          Hope this helps another server newbie some day.

           

          -Mike