AnsweredAssumed Answered

Need to increase the Idle Timeout for Filemaker Pro Server Web Server

Question asked by lezone on Feb 11, 2009
Latest reply on Nov 15, 2010 by ChristineT.


Need to increase the Idle Timeout for Filemaker Pro Server Web Server

Your post



We are using Filemaker Pro to serve up a web interface to our company for use by the employees.  The problem is that the connection keeps timeing out when idle for more than 15 minutes.  This is extremely annoying to the users and we'd like to increse this time.  There are two questions I have related to this.


First, we've found two "Session Timeout" settings under Web Publishing on the server, one under the XSLT tab and the other under the Instant Web Publishing tab.  Weve set both of these to the maximum time of 60 minutes but are still only seeing idle timeout times of 15 minutes. Is there another place where a setting effecting this might be hidden or is this a bug or some other problem we are missing?


Second, even 60 minutes is really too short of a time for us.  We'd rather have 6 to 12 hours of idle before auto disconnect.  Is this possible?  What about from the command line?


We're serving up out databases with the latest version of Filemaker Pro Server on a brand new Mac Mini to around 20 linux boxes accessing the databases via Firefox.  (Is it possible that Firefox has a setting that is the culprit?)  There are also 7 or 8 Macs accessing the databases via FM Pro (various versions 9 to 10) though they are obviously not experiencing this issue.


Any thoughts out there that might be able to help us?  Thanks,